Aggressive cows (二分)


Aggressive cows

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 37   Accepted Submission(s) : 13
Problem Description
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
 

Input
* Line 1: Two space-separated integers: N and C<br><br>* Lines 2..N+1: Line i+1 contains an integer stall location, xi
 

Output
* Line 1: One integer: the largest minimum distance
 

Sample Input
  
  
5 3 1 2 8 4 9
 

Sample Output
  
  
3
 

Source
PKU
 

题意:给你n个坐标,求c个坐标中最小的最大距离。

思路:

一看题目是最小值得最大值,立刻想到二分。对坐标进行排序。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#include <iomanip>
#define maxn 15
#define mod 1000000007
#define INF 0x3f3f3f3f
#define exp 1e-6
#define pi acos(-1.0)
using namespace std;
int a[100005];
int main()
{
    ios::sync_with_stdio(false);  //不加这句话会超时
    int n,c;
    int i,j;
    cin>>n>>c;
    int m=n-c;  //需要去掉的个数
    memset(a,0,sizeof(a));
    for(i=1;i<=n;i++)cin>>a[i];
    sort(a+1,a+n+1);
    int left=0,right=a[n],mid;
    while(right>left)
    {
        int cnt=0;
        mid=(left+right)/2;
        for(i=2,j=1;i<=n;){   //从第二个开始和第一个进行比较
            if(a[i]-a[j]<=mid){cnt++;i++;}
            else {j=i;i++;}
        }
        if(cnt>m) right=mid;  
        else left=mid+1; //扩大
    }
    cout<<left<<endl;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值