Copying Books (二分法)

Copying Books

Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 55   Accepted Submission(s) : 22
Problem Description
Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.

Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered 1, 2 ... m) that may have different number of pages (p1, p2 ... pm) and you want to make one copy of each of them. Your task is to divide these books among k scribes, k <= m. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers 0 = b0 < b1 < b2, ... < b k-1 <= bk = m such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.
 

Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k, 1 <= k <= m <= 500. At the second line, there are integers p1, p2, ... pm separated by spaces. All these values are positive and less than 10000000.
 

Output
For each case, print exactly one line. The line must contain the input succession p1, p2, ... pm divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character ('/') to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash. <br><br>If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.
 

Sample Input
  
  
2 9 3 100 200 300 400 500 600 700 800 900 5 4 100 100 100 100 100
 

Sample Output
  
  
100 200 300 400 500 / 600 700 / 800 900 100 / 100 / 100 / 100 100
 

Source
PKU

题意:给你n本书的页数。然后有m个人,每个人至少要抄一本书,或者连续的几本书。每个人的工作量就等于他要抄的书的页数之和。问怎样划分能使工作量的最大值最小。这里要求答案如果有多种的话就输出前面的和比较小的那个划分。

思路:最大值最小化问题。

二分尝试可能的最大值,然后如果在这个最大值的情况下可以划分的话,说明最大值可能是这个值,也可能更小。如果不能划分的话说明这个最大值不够大。
划分的时候从后面往前面划分,保证后面的比较大。  注意用 long long

图片摘自:http://blog.csdn.net/shuangde800/article/details/7828695

代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=1005;
int n,T;
long long num[maxn],sum[maxn],vis[maxn]; //num存储数据,sum记录到每个数的和,vis确定到哪点输出/
int main()
{
    long long t,left,right,mid;
    cin>>t;   
    while(t--){
	memset(num,0,sizeof(num));  //初始化
	memset(sum,0,sizeof(sum));
	memset(vis,0,sizeof(vis));
	left=right=0;
	cin>>n>>T;
	for (int i=1;i<=n;i++)
	{
	    cin>>num[i];
	    sum[i]=sum[i-1]+num[i];
	    left = max(left,num[i]);
	}
	right = sum[n];
	while (left!= right)        //二分查找
    {
	    mid=(right+left)/2;
	    long long cntt=0,f=0,e=1;
        while (e<=n)
        {
	      if (sum[e]-sum[f]>mid) {cntt++;f=e-1;}
	      e++;
        }
	    if (cntt<=T-1)   //说明是大了,要减小
	    {
		right=mid;
	    }
	    else
		left=mid+1;  //说明是小了,要增大
	}
//	printf("%d\n",left);
	long long now=0,cnt=0;  //now表示到现在的和,cnt代表/个数
	for (int i=n;i>0;i--)
    {
	    if (now+num[i]>left||i<T-cnt)
        {
		vis[i] = 1;
		cnt++;
		now=num[i];
	    }
	    else
		now+=num[i];
	}
	for (int i=1;i<n;i++){        //输出
        cout<<num[i]<<' ';
	    if(vis[i]) cout<<"/ ";
	}
	cout<<num[n]<<endl;
    }
    return 0;
}
心得:

题目稍微复杂,但是万变不离其中,还是用二分法解决最大值最小化问题。

  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值