Largest Rectangle in a Histogram (单调队列||dp)

Largest Rectangle in a Histogram

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 47   Accepted Submission(s) : 14
Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer <i>n</i>, denoting the number of rectangles it is composed of. You may assume that <i>1<=n<=100000</i>. Then follow <i>n</i> integers <i>h<sub>1</sub>,...,h<sub>n</sub></i>, where <i>0<=h<sub>i</sub><=1000000000</i>. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is <i>1</i>. A zero follows the input for the last test case.
 

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input
  
  
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
 

Sample Output
  
  
8 4000
 

Source
PKU
 

题意:给出一些宽度为1,高度大于等于0的矩形,求出最大的矩形面积。

思路:

要维护两个单调队列,lft和rit。lft [i]表示i点,左边连续有比i点高的柱子的话,把最左边的柱子编号记录在lft [i]。 rit 同理,记录i的最右边连续比i高的柱子的编号。有了lft 和rit 就可枚举每一列计算那一列向两遍扩展的最大的宽了。再乘上该列的高,就是包含该列的最大的面积了。

因为      a[l[i]+1]>a[i],所以l[i]=l[l[i]+1]。
同理:  a[r[i]-1]>a[i],所以r[i]=r[r[i]-1]。

代码:

#include <iostream>
#include <algorithm>
#include <stdio.h>
using namespace std;
const int maxn=1000005;
long long h[maxn];
long long lit[maxn],rit[maxn];
int main()
{
    ios::sync_with_stdio(false);  //不加这句话超时
    long long n,i;
    while(cin>>n,n)
    {
        for(i=1;i<=n;i++){cin>>h[i];lit[i]=rit[i]=i;}
        h[0]=h[n+1]=-1;
        for(i=1;i<=n;i++)    //寻找左边大于他得
        {
            while(h[i]<=h[lit[i]-1])lit[i]=lit[lit[i]-1];
        }
        for(i=n;i>=1;i--)
        {
            while(h[i]<=h[rit[i]+1])rit[i]=rit[rit[i]+1];   //寻找右边高度大于它的
        }
        long long maxx=0;
        for(i=1;i<=n;i++)
            maxx=max(maxx,h[i]*(rit[i]-lit[i]+1)); 
        cout<<maxx<<endl;
    }
    return 0;
}

单调队列代码:

#include<iostream>  
#include<stdio.h>  
using namespace std;  
int main()  
{  
    long long int a[100010];  
    int l[100010];  
    int r[100010];  
    int s[100010];  
    int N;  
    int top;  
    while(cin>>N && N)  
    {  
        for(int i=1;i<=N;i++)  
        {  
            scanf("%I64d",&a[i]);  
            l[i]=i;  
            r[i]=i;  
        }  
        top=0;  
        for(int i=1;i<=N;i++)   //向左找  
        {  
            while(top && a[i]<=a[s[top]])  
                top--;  
            if(top==0)  
                l[i]=1;  
            else  
                l[i]=s[top]+1;//s[top]存的数的值肯定是比a[i]小的,所以地s[top]+1个位置即为所求  
            s[++top]=i;  
        }  
        top=0;  
        for(int i=N;i>=1;i--)  
        {  
            while(top && a[i]<=a[s[top]])  
                top--;  
            if(top==0)  
                r[i]=N;  
            else  
                r[i]=s[top]-1;  
            s[++top]=i;  
        }  
        long long int maxn=0;  
        long long int area;  
        for(int i=1;i<=N;i++)  
        {  
            area=a[i]*(r[i]-l[i]+1);  
            if(maxn<area)  
                maxn=area;  
        }  
        printf("%I64d\n",maxn);  
    }  
    return 0;  
}  



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值