Bad Cowtractors(求最大生成树 Kruskal变形)

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie.  

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".
Input
* Line 1: Two space-separated integers: N and M  

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.
Output
* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.
Sample Input
5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17
Sample Output
42
Hint
OUTPUT DETAILS:  

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

题意:Bessie要在John的N个谷仓之间修路,John要求用尽可能少的路使得所有谷仓都能联通,并且总距离最短,但是他又不想给Bessie钱。Bessie已经意识到John可能不给他钱,所以他就想把这个工程做的最糟糕并且不让John发现。他决定用尽可能少的路使得所有谷仓都能联通,但是要使总距离尽可能长。求这个可能的总距离。如果不能使得所有谷仓都联通,则输出"-1"。
思路:和最小生成树的求法类似,这里使边的权值尽可能大。用Kruskal算法来做,排序的时候,将边从大到小排序。因为Kruskal算法过程中要先判断两点是否联通,而且边是大到小排序,所以如果两点间有重边,则优先选择大的加入生成树中。其实就是Kruskal的变形,

代码:

#include <iostream>
#include <cstring>
#include <stdio.h>
#include <algorithm>
using namespace std;
struct edgenode{
int from;
int to;
int w;
}edge[40040];
int father[1100];
int find(int x)   //并查集
{
    if(x!=father[x])
        father[x]=find(father[x]);
    return father[x];
}
int cmp(edgenode a,edgenode b)  //排序,注意此处和最小生成树不同,这是将所有边用快排由大到小排序。
{
    return a.w>b.w;
}
void kruskal(int n,int m)  //Kruskal算法
{
    sort(edge,edge+m,cmp);
    int tot=0,k=0;//k为计数器
    for(int i=0;i<m;i++)
    {
        int u=find(edge[i].from);
        int v=find(edge[i].to);
        if(u!=v)  //不属于同一并查集
        {
            tot+=edge[i].w;  //加上值
            father[v]=u;  //让其进入最大生成树
            k++;
            if(k==n-1)break;  //如果k=n-1说明最小生成树已经生成则break;
        }
    }
    if(k==n-1)cout<<tot<<endl;
    else
        cout<<"-1"<<endl;

}
int main()
{
    int n,m;
    int i;
    while(cin>>n>>m)
    {
        for(i=1;i<=n;i++)father[i]=i;  //初始化并查集
        for(i=0;i<m;i++)
        {
            cin>>edge[i].from>>edge[i].to>>edge[i].w;
        }
        kruskal(n,m);
    }


}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值