Matrix(二维数状数组+求和+区间更新+单点查询)

Problem P

Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 65   Accepted Submission(s) : 27
Problem Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 
 

Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. <br> <br>The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. <br>
 

Output
For each querying output one line, which has an integer representing A[x, y]. <br> <br>There is a blank line between every two continuous test cases. <br>
 

Sample Input
  
  
1 2 10 C 2 1 2 2 Q 2 2 C 2 1 2 1 Q 1 1 C 1 1 2 1 C 1 2 1 2 C 1 1 2 2 Q 1 1 C 1 1 2 1 Q 2 1
 

Sample Output
  
  
1 0 0 1

题意:

给出矩阵左上角和右下角坐标,矩阵里的元素 1变0 ,0 变1,然后给出询问,问某个点是多少?

思路:

此题的关键就是要知道单点查询就是求和了。因为初始化全为0,题目告诉我们不是1就是0这个特点,这样我们只需记录每个格子改变过几次(可以%2),即可判断这个格子的数字。注意格式的输出(QAQ)

代码:

#include <iostream>
#include <cstring>
#include <stdio.h>
#include <algorithm>
#define maxn 1010
using namespace std;
int a[maxn][maxn];
int N;
int lowbit(int i)
{
	return i&-i;
}
int sum(int i,int j)  //求和
{
	int summ=0;
	while(i>0){
		int jj=j;
		while(jj>0){
			summ+=a[i][jj];
			jj-=lowbit(jj);
		}
		i-=lowbit(i);
	}
	return summ;
}
void add(int i,int j,int x){  //区间更新
	while(i<=N){
		int jj=j;
		while(jj<=N){
		a[i][jj]+=x;
		jj+=lowbit(jj);
		}
	i+=lowbit(i);
	}
}
int main()
{
	int X,T;
	int i,j;
	int x1,x2,y1,y2;
	char ch;
	scanf("%d",&X);
	while(X--)
	{
		memset(a,0,sizeof(a));
		scanf("%d%d",&N,&T);
		for(i=1;i<=T;i++)
		{
			scanf("%s",&ch);
			if(ch=='C')
			{
			 scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
			 add(x1,y1,1);
			 add(x1,y2+1,-1);
			 add(x2+1,y1,-1);
			 add(x2+1,y2+1,1); //加上减去两次的部分
			}
			else
			{
				 scanf("%d%d",&x1,&y1);  
				printf("%d\n",sum(x1,y1)%2);
			}
			
		}
		printf("\n");
	}
	return 0;
} 




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值