MooFest(数状数组)

Problem P

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 43   Accepted Submission(s) : 24
Problem Description
Every year, Farmer John's N (1 <= N <= 20,000) cows attend "MooFest",a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing. 

Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)). 

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume. 

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows. 
 

Input
* Line 1: A single integer, N <br> <br>* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location. <br>
 

Output
* Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows. <br>
 

Sample Input
   
   
4 3 1 2 5 2 6 4 3
 

Sample Output
   
   
57
 

Statistic |  Submit |  Back

题意:

给定n头牛的听力和坐标,每两头牛交谈需要(max(v(i),v(j) )*abs(dis[i]-dis[j])),n头牛总共要交谈(n*(n-1)/2)次

思路:

1.首先将这n个点按照v值从小到大排序(后面说的排在谁的前面,都是基于这个排序)。这样,当i<j时有max{vi,vj}=vj

2.用两个树状数组,一个记录比xi小的点的个数a,一个记录比xi小的点的位置之和b,然后,我们可以快速地求出xi与比xi小的点的所有距离的绝对值之和:a*x[i]-b,
也可以方便地求出xi与比xi大的点的所有距离的绝对值之和:所有距离-b-(i-1-a)*x[i]。将二者相加,乘上vi,再把所有结果相加即可。

代码:

#include<stdio.h>  
#include<iostream>  
#include<string.h>  
#include<cstring>  
#include<algorithm>
typedef long long ll;
using namespace std;  
const int maxn =20001;
long long num[2][maxn];   //num[0]代表求比xi小的数的个数,num[1]表示xi小的位置之和
int lowbit(int x){
	return x&-x;
}

struct node{  
	ll x,v;
	bool operator <(const node &a)const{
	return v<a.v;
	}
}q[maxn];   
//-------------------------------0 1
void update(int x,ll v,int d)  
{
	while(x<maxn){
		num[d][x]+=v;
		x+=lowbit(x);
		//cout<<num[d][x]<<"------"<<endl;
	} 
} 

ll sum(int x,int d){
	ll res=0;
	while(x>0){
		res+=num[d][x];
		x-=lowbit(x);
	}
	return res;
}

int main()  
{
	ios::sync_with_stdio(false);
	int n;
	cin>>n;
	memset(num,0,sizeof(num));
	for(int i=1;i<=n;i++){
		cin>>q[i].v>>q[i].x;
	}
	sort(q+1,q+1+n);
	ll a,b,ans=0;
	int i=1;
	while(i<n){
	    update(q[i].x, 1, 0);//sl
        update(q[i].x, q[i].x, 1);
        a = sum(q[++i].x, 0);  
        b = sum(q[i].x, 1);  
        ans += (sum(maxn - 1, 1) - (b << 1) - (i - 1 - (a << 1)) * q[i].x) * q[i].v;
	}
	cout<<ans<<endl;
    return 0;  
}  




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值