Watchcow (欧拉回路+路径输出)

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done. 

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice. 

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.
Input
* Line 1: Two integers, N and M. 

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.
Output
* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.
Sample Input
4 5
1 2
1 4
2 3
2 4
3 4
Sample Output
1
2
3
4
2
1
4
3
2
4
1
Hint
OUTPUT DETAILS: 

Bessie starts at 1 (barn), goes to 2, then 3, etc...

题意:

现在有N个农场和M条路,要求你走过这M条路每条2次且这两次是反向的.要你输出从1号农场走到完所有M条路两次之后回到1号农场的点的轨迹.保证这种轨迹存在.其中点(农场)从1开始编号到N.

思路:

需要注意的是,本题目数据太大,如果遍历每个,那么肯定会超时,所以此处用邻接表来保存边。

代码:

#include<cstdio>  
#include<cstring>  
#include<vector>  
#include<queue>  
using namespace std;  
const int maxn=50000+100; 
int n,m;
int head[maxn];
int cnt;
struct Edge{
	int to;
	int next;
	bool vis;
}edge[maxn*3];

void add(int u,int v){
	edge[cnt].to=v;
	edge[cnt].next=head[u];
	edge[cnt].vis=0;
	head[u]=cnt++;
}

void euler(int u){
	for(int s=head[u];s!=-1;s=edge[s].next) if(!edge[s].vis){
		edge[s].vis=true;
		euler(edge[s].to);
	}
	printf("%d\n",u);
}

int main()  
{
	cnt=0;
	memset(head,-1,sizeof(head));
//	memset(ans,0,sizeof(ans));
	scanf("%d%d",&n,&m);
	for(int i=1;i<=m;i++){
		int u,v;
		scanf("%d%d",&u,&v);
		add(u,v);
		add(v,u);
	}
	euler(1);
    return 0;  
}  

地址: 点击打开链接



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值