HDU——1009 FatMouse' Trade (贪心水题)

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

解题思路:

简单贪心算法 , 计算单价 , 按单价从大到小排个序 , 先挑大的拿。

代码:

#include<cstdio>
#include<algorithm>
using namespace std;

typedef struct{
    int j;    //可以换取的
    int f;    //用来换的
    double v;
}value;

value ans[1010];

bool method(value a , value b){
    return a.v > b.v;
}
int main(){
    //freopen("D://testData//1009.txt" , "r" , stdin);
    int m , n , i ;
    double result;
    while(scanf("%d %d",&m , &n) != EOF){
        if(m == -1 && n == -1)
            break;
        result = 0;
        for(i = 0 ; i < n ; i ++){
            scanf("%d %d",&ans[i].j , &ans[i].f);
            ans[i].v = (double)ans[i].j / ans[i].f;
        }

        sort(ans , ans + n  , method);

        for(i = 0 ; i < n ; i ++){
            if(m >= ans[i].f){
                result = result + ans[i].j;
                m = m - ans[i].f;
            }else{
                result = result + ans[i].v * m;
                break;
            }
        }

        printf("%.3f\n",result);

    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值