九度OJ题目1154-Jungle Roads

题目描述:

                                                
   The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

输入:
    The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

输出:
    The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

样例输入:
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
样例输出:
216
30

题目大意:

第一行表示结点数n,接下来n-1行,每行的第一个数表示哪个结点(节点名是字母表中按顺序的前n个,且均为大写字母),第二个数字表示该结点与几个结点相连,后面分别为结点名以及两结点之间的花费,最后求出所有结点都联通时的最小花费(其实就是求一个图中的最小生成树问题)。

参考代码:

/*并查集和kruskal算法*/
 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
/*
   注意结点的下标均从1开始
   由于边数是累加而来的,注意排序时,以及集合合并时,不要数组溢出
*/

#define N 30
int  Tree[N];
int findRoot(int x) {
	if (Tree[x] == -1) return x;
	else {
		int tmp = findRoot(Tree[x]);
		Tree[x] = tmp;
		return tmp;
	}
}
struct Edge {
	int a, b;
	int cost;
	bool operator<(const Edge &A)const {
		return cost < A.cost;
	}
}edge[501];
int main() {
	int n,m;
	char s[2],s2[2];
	int c;
	while (scanf("%d", &n) != EOF) {
		if (n == 0) break;
		int cnt = 1;
		for (int i = 1; i <n; i++) {
			scanf("%s%d", s, &m);		
			while (m--) {
				scanf("%s%d", s2, &c);
				edge[cnt].a = s[0] - 'A' + 1;
				edge[cnt].b = s2[0] - 'A' + 1;
				edge[cnt].cost = c;
				cnt++;
			}
		}
		sort(edge+1, edge + cnt);
		
		for (int i = 1; i <= n; i++) {
			Tree[i] = -1;
		}
		int ans = 0;
		for (int i = 1; i <cnt; i++) {
			int a = findRoot(edge[i].a);
			int b = findRoot(edge[i].b);
			if (a != b) {
				Tree[b] = a;
				ans += edge[i].cost;
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}

/*Prime算法,使用邻接矩阵存储图*/

/*
使用Prime算法求解最小生成树
*/
#include<cstdio>
#include<iostream>
using namespace std;
const int INF = 123123123;
int dis[30];//dis[i]某结点与i结点之间的花费(记录与该结点相连的结点之间的花费)
int a[30][30];
int vis[30];
int n, m;
int prime() {
	for (int i = 1; i <= n; i++){//初始化
		dis[i] = a[1][i];
		vis[i] = false;
	}
	dis[1] = 0;
	vis[1] = true;
	int ans = 0;
	for (int i = 2; i <= n; i++) {
		int p = -1;
		int min = INF;
		for (int j = 1; j <= n; j++) {//找出权值最小的边
			if (!vis[j] && dis[j] < min) {
				p = j;
				min = dis[j];
			}
		}
		ans += min;
		vis[p] = true;
		for (int j = 2; j <= n; j++) {//存储下一个结点的所有的待选边的权值,不含已选边(结点集(包含旧结点)所以不是直接复制,而是选择新结点的较小的边)
			if (!vis[j] && dis[j] > a[p][j])
				dis[j] = a[p][j];
		}
	}
	return ans;
}
int main() {
	while (cin >> n, n) {
		for (int i = 1; i <= n; i++) {
			for (int j = 1; j <= n; j++)
				a[i][j] = INF;
			a[i][i] = 0;
		}
		char c1, c2;
		int x, y;
		for (int i = 1; i < n; i++) {
			cin >> c1 >> x;
			while (x--) {
				cin >> c2 >> y;
				if (a[c1 - 'A' + 1][c2 - 'A' + 1] > y) {
					a[c1 - 'A' + 1][c2 - 'A' + 1] = y;
					a[c2 - 'A' + 1][c1 - 'A' + 1] = y;
				}
			}
		}
		cout << prime() << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值