【kruskal裸题】 POJ - 1251 Jungle Roads

【kruskal裸题】 POJ - 1251 Jungle Roads


【vj链接】
【poj链接】

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
Output
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.


第一次用kruskal,直接把并查集函数改了改就上了


题目大意

多组数据,
每组数据第一行为n个村庄,编号为A到(A+n-1),
接下来n-1行每行第一个数据表示这个村庄,第二个数表示有几条路,接下来分别是到哪个村庄,路程为多少
输入以0结束
求最短连通图

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

解题思路

把所有道路存下来排序,开始时每个村庄的father都是自己,然后按顺序搜每条路两端的村庄,如果祖先不同加入同一阵营并在最后答案里加上这条路。


AC代码

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
#define LL long long

int father[30];
int find_father(int x)
{
    if(x==father[x])
        return x;
    return father[x]=find_father(father[x]);
}
bool join(int x,int y)
{
    int fx=find_father(x),fy=find_father(y);
    if(fx!=fy)
    {
        father[fy]=fx;
        return 1;
    }
    return 0;
}
struct node
{
    int be,to,v;
}edge[101];
int cmp(node a,node b)
{
    return a.v<b.v;
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n!=0)
    {
        char x,y;
        int m,w,ans=0;;
        int cnt=0;
        for(int i=0;i<26;i++)
            father[i]=i;
        for(int i=0;i<n-1;i++)
        {
            cin>>x>>m;
            for(int j=0;j<m;j++)
            {
                cin>>y>>w;
                edge[cnt].be=x-'A';
                edge[cnt].to = y - 'A';
                edge[cnt].v = w;
                cnt ++;
            }
        }
        sort(edge,edge+cnt,cmp);
        for(int i=0;i<cnt;i++)
        {
            if(join(edge[i].be,edge[i].to))
                ans+=edge[i].v;
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Kruskal-Wallis H检验是一种用于比较三个或更多组之间差异的非参数统计检验方法。假设我们对不同品牌汽车的燃油效率进行了调查,并将数据分成了三个组:品牌A、品牌B和品牌C。我们想要知道这三个品牌汽车的燃油效率是否存在显著的差异。 首先,我们将收集到的数据按照品牌分成三组,并对每组的燃油效率进行排名。然后,我们使用Kruskal-Wallis H检验来比较这三组数据的中位数是否有显著差异。在进行检验前,需要对数据进行正态性检验和方差齐性检验。如果数据不满足正态性和方差齐性的要求,可以使用Kruskal-Wallis H检验来代替方差分析。 Kruskal-Wallis H检验的零假设是三组数据的中位数没有显著差异,备择假设是三组数据的中位数存在显著差异。通过计算得出的H统计量与临界值比较,如果H统计量大于临界值,则拒绝零假设,说明三组数据的中位数存在显著差异。 通过Kruskal-Wallis H检验,我们可以得出结论:在显著水平α=0.05下,品牌A、品牌B和品牌C的燃油效率存在显著差异/不存在显著差异。这样的分析结果可以为消费者选择汽车提供参考,也可以为汽车制造商改进产品提供指导。Kr使用Kruskal-Wallis H检验能够帮助我们做出合理的决策和判断。uskal-Wallis H检验是一个非常有用的统计工具,可以在不满足方差齐性和正态性的条件下对多组数据进行比较,为研究和实践提供了很大的便利。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值