1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02
Sample Output:
0 1

void DFX(Vertex S){
	visited[S]=true;
	level++;
	for(S的每个孩子结点V){
		if(visited[V]==flase) {
			DFS(V);
		}
	}
	if(这样的V不存在){
		NoChild[level]++;
	}
}
#include<stdio.h>
#include<stdlib.h>
#include<stdbool.h>

#define MaxVertexNum 100
#define INFINITY 35565

typedef int Vertex;
typedef int WeightType;

typedef struct GNode *PtrToGNode; 
struct GNode{
	int Nv;
	int Ne;
	WeightType G[MaxVertexNum][MaxVertexNum];
};
typedef PtrToGNode MGraph;

typedef struct ENode *PtrToENode;
struct ENode{
	Vertex V1, V2;
}; 
typedef PtrToENode Edge;

MGraph CreateGraph(int N){
	Vertex V, W;
	MGraph Graph;
	Graph = (MGraph)malloc(sizeof(struct GNode));
	Graph->Nv = N;
	for(V=1; V<=Graph->Nv; V++)
		for(W=1; W<=Graph->Nv; W++)
			Graph->G[V][W] = INFINITY;
	
	return Graph;
}

void Insert(Edge E, MGraph Graph){
	Graph->G[E->V1][E->V2] = 1;
}

MGraph BuildGraph(){
	int N;
	int i, j, k;
	Vertex V1, V2;
	MGraph Graph;
	Edge E;
	E = (Edge)malloc(sizeof(struct ENode));
	scanf("%d", &N); 
	Graph = CreateGraph(N);
	scanf("%d", &Graph->Ne); 
	for(i=0; i<Graph->Ne; i++){
		scanf("%d", &E->V1);
		scanf("%d", &k);
		for(j=0; j<k; j++){
			scanf("%d", &E->V2); 
			Insert(E, Graph);
		}		
	}
	return Graph;
}

void DFS(MGraph Graph, Vertex S, bool visited[], int level, int NoChildNumber[], int* maxlevel){
	Vertex V;
	visited[S] = true;
	int flag=0;
	level++; 
	if(*maxlevel < level) *maxlevel = level;
	for(V=1; V<=Graph->Nv; V++){
		if(Graph->G[S][V] == 1 && visited[V] == false ){
			DFS(Graph, V, visited, level, NoChildNumber, maxlevel);
			flag=1;
		}
	}
	if(flag==0){
		NoChildNumber[level]++; 
	}
}


void PrintfResult(int NoChildNumber[], int maxlevel){
	int i;
	printf("%d", NoChildNumber[1]);
	for(i=2; i<=maxlevel; i++){
		printf(" %d", NoChildNumber[i]);
	}
}

int main(){
	MGraph Graph;
	Graph = BuildGraph();  
	
	int i; 
	bool visited[Graph->Nv+1];
	int level = 0;
	int NoChildNumber[Graph->Nv+1];
	int maxlevel=0;
	for(i=1;i<=Graph->Nv;i++){
		visited[i] = false;
		NoChildNumber[i] = 0;
	}
	
	DFS(Graph, 1, visited, level, NoChildNumber, &maxlevel);
	PrintfResult(NoChildNumber, maxlevel);
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值