Duizi and Shunzi(贪心)

Nike likes playing cards and makes a problem of it.

Now give you n integers, ai(1in)

We define two identical numbers (eg: 2,2) a Duizi,
and three consecutive positive integers (eg: 2,3,4) a Shunzi.

Now you want to use these integers to form Shunzi and Duizi as many as possible.

Let s be the total number of the Shunzi and the Duizi you formed.

Try to calculate max(s)
.

Each number can be used only once.
Input The input contains several test cases.

For each test case, the first line contains one integer n( 1n106).
Then the next line contains n space-separated integers ai ( 1ain)
Output For each test case, output the answer in a line.
Sample Input
7
1 2 3 4 5 6 7
9
1 1 1 2 2 2 3 3 3
6
2 2 3 3 3 3 
6
1 2 3 3 4 5
Sample Output
2
4
3
2


        
  
Hint
Case 1(1,2,3)(4,5,6)

Case 2(1,2,3)(1,1)(2,2)(3,3)

Case 3(2,2)(3,3)(3,3)

Case 4(1,2,3)(3,4,5)



        
 


这道题看起来好像只能用dp,其实正解贪心就可以了。(还是太年轻)

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>

typedef long long LL;
using namespace std;
int a[1000010];
int book[1000010];
int main()
{
    int n,ans;
    while(scanf("%d",&n)!=EOF){
            ans=0;
            memset(book,0,sizeof(book));
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            book[a[i]]++;
        }
        for(int i=1;i<=n;i++){
            if(book[i-1]==1&&book[i-2]==1&&book[i]>0){
                ans++;
                book[i]--;
                book[i-2]--;
                book[i-1]--;
            }//先处理前面只剩一个而且又能组成顺子的数
            ans=ans+book[i]/2;//处理对子
            book[i]=book[i]%2;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值