POJ - 2155 Matrix-----树状数组

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 33058 Accepted: 11972

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

题意:两个操作,一个查询,一个修改:通过对走上角(x1,y1)右下角(x2,y2)的矩阵进行修改使矩阵内的值进行0、1反转

这道题直接套用二维的树状数组进行单点查询,区间修改的模板即可。

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
int a[1005][1005],n;
int lowbit(int i)
{
    return i&(-i);
}
void modify(int x,int y)
{
    for(int i=x;i>=1;i-=lowbit(i))
        for(int j=y;j>=1;j-=lowbit(j))
        a[i][j]++;
}
void ask(int x1,int y1,int x2,int y2)
{
    modify(x2,y2);
    modify(x1-1,y2);
    modify(x2,y1-1);
    modify(x1-1,y1-1);
}
int query(int x,int y)
{
    int ans=0;
    for(int i=x;i<=n;i+=lowbit(i))
        for(int j=y;j<=n;j+=lowbit(j))
            ans+=a[i][j];
    return ans%2;
}
int main()
{
    int t,k;
    scanf("%d",&t);
    char s;
    while(t--)
    {
        memset(a,0,sizeof(a));
        scanf("%d%d",&n,&k);
        for(int i=0;i<k;i++)
        {
            getchar();
            scanf("%c",&s);
            if(s=='C')
            {
                int x1,y1,x2,y2;
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                ask(x1,y1,x2,y2);
            }
            else{
                int x,y;
                scanf("%d%d",&x,&y);
                printf("%d\n",query(x,y));
            }
        }
        printf("\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值