PAT (Advanced Level) Practice 1009 Product of Polynomials(Python)

程序员入门水平,贴出代码大家一起进步!
原题传送门

题目

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K    N 1    a N 1    N 2    a N 2 …    N k    a N k K\;N_1\;a_{N1}\;N_2\;a_{N2}\dots\;N_k\;a_{Nk} KN1aN1N2aN2NkaNk
where K is the number of nonzero terms in the polynomial, N i N_i Ni and a N i    ( i = 1 , 2 , ⋯ , K ) a_{Ni}\;(i=1,2,⋯,K) aNi(i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1 ≤ K ≤ 10 , 0 ≤ N K < ⋯ < N 2 < N 1 ≤ 1000 1≤K≤10, 0≤N_K <⋯<N_2<N_1 ≤1000 1K10,0NK<<N2<N11000 .
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

思路||总结

  • 设置20001初始值为0的列表,对于两个因子,将其系数的乘积加在列表位置为两个因子的幂的和的位置。
  • count一下又多少个非零项,然乎输出。

AC代码

import numpy as np


def main():
    str_0 = input().strip().split()
    str_0[0] = int(str_0[0])
    for i in range(str_0[0]):
        str_0[i * 2 + 1] = int(str_0[i * 2 + 1])
        str_0[i * 2 + 2] = float(str_0[i * 2 + 2])
    str_1 = input().strip().split()
    str_1[0] = int(str_1[0])
    for i in range(str_1[0]):
        str_1[i * 2 + 1] = int(str_1[i * 2 + 1])
        str_1[i * 2 + 2] = float(str_1[i * 2 + 2])
    result = np.zeros(2001)
    count = 0
    for i in range(str_0[0]):
        for j in range(str_1[0]):
            # 对于两个因子,将其系数的乘积加在列表位置为两个因子的幂的和的位置
            result[str_0[i * 2 + 1] + str_1[j * 2 + 1]] += str_0[i * 2 + 2] * str_1[j * 2 + 2]
    # 数一下有多少个非0项
    for i in range(2001):
        if result[i] != 0:
            count += 1
    print(count, end='')
    for i in range(2001):
        if result[2000 - i] != 0:
            print(' %d %.1f' % (2000 - i, result[2000 - i]), end='')


main()

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值