PAT A1009:Product of Polynomials(Python迭代器的使用)

题目内容

This time, you are supposed to find A × B A\times B A×B where A A A and B B B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K K K N 1 a N 1 N 2 a N 2 ⋯ N K a N K N_1 a_{N_1} N_2 a_{N_2} \cdots N_K a_{N_K} N1aN1N2aN2NKaNK

where K K K is the number of nonzero terms in the polynomial, N i N_i Ni and a N i ( i = 1 , 2 , ⋯   , K ) a_{N_i} (i=1,2,\cdots,K) aNi(i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1 ⩽ K ⩽ 10 1\leqslant K\leqslant 10 1K10 0 ⩽ N K < ⋯ < N 2 < N 1 ⩽ 1000 0\leqslant N_K < \cdots < N_2 < N_1 \leqslant 1000 0NK<<N2<N11000.

Output Specification:

For each test case you should output the product of A A A and B B B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6

题目要点

本题 25 分,是比较简单的模拟题。在输入时,Python可以不用考虑给定的 K K K,直接用数组切片隔位取指数列表、系数列表,再用zip()构造字典。

重点需要考虑的是如何将多项式的指数和对应系数映射。C/C++可以用数组下标作为指数,数组浮点数值为对应系数。这里Python使用字典比较方便,而且考虑到两个多项式的指数项不一定相同,在求和时要指数项系数对应相加,Python可以使用集合的求并集|运算符实现。

注意,测试点6是非零系数项个数,也就是 K K K为0的情况,这时候只输出0。如果有多余空格会出现“格式错误”。

AC 源代码

from itertools import product

ins1 = input()
ins2 = input()
a = zip( map(int, ins1.split()[1::2]), map(float, ins1.split()[2::2]) )
b = zip( map(int, ins2.split()[1::2]), map(float, ins2.split()[2::2]) )

poly = {}
prod = map(lambda x: (x[0][0]+x[1][0], x[0][1]*x[1][1]), product(a, b))

for exp, coef in prod:
    poly[exp] = poly.get(exp, 0.0) + coef

poly = list( filter(lambda x:x[1]!=0.0, sorted(poly.items(), reverse=True)) )
line = ' '.join(map(lambda x: '{:d} {:.1f}'.format(*x), poly))
k = len(poly)

if k:
    print(k, line)
else:
    print(0)

参考来源

A1002多项式加法的解析:https://column.mowchan.me/post/2021/pat-a1002.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值