PTA(甲级)1013 Battle Over Cities (25分)

题目来源:PTA(甲级)1013 Battle Over Cities (25分)
题目描述:
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​ -city​2 and city​1​​ -city​3​​ . Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​ -city​3​​ .

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:
3 2 3
1 2
1 3
1 2 3
Sample Output:
1
0
0

题目大意:
给出n个城市之间有相互连接的m条道路,当删除一个城市和其连接的道路的时候,求出至少要添加多少个路线才能让城市之间重新连通。

注意: 如果用cout进行输出会出现超时的结果

#include<iostream>
using namespace std;


int map1[1000][1000] = { 0 };
int tmp[1000] = { 0 };
int N, M, K, c1, c2, city;
void dfs(int v)
{ 
	tmp[v] = 1;
	for (int i = 1;i <= N;i++)
	{
		if (map1[v][i] == 1 && tmp[i] == 0)
		{
			dfs(i);
		}
	}
}

int main() 
{	
	cin >> N >> M >> K;
	for (int i = 0;i < M;i++)
	{
		cin >> c1 >> c2;
		map1[c1][c2] = map1[c2][c1] = 1;
	}
	/*for (int i = 1;i <= N;i++) //矩阵输出测试
	{  
		for (int j = 1;j <= N;j++)
			cout << map1[i][j] << " ";
		cout << endl;
	}*/
	for (int i = 0;i < K;i++)
	{
		
		for (int j = 1;j <= N;j++)
			tmp[j]=0;
		cin >> city;
		int num = 0;
		tmp[city] = 1;
		for (int j = 1;j <= N;j++)
		{
			if (tmp[j] == 0)
			{
				num++;
				dfs(j);
			}
		}
		printf("%d\n", num - 1);  //不能用cout,超时
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值