PTA(甲级)1012 The Best Rank (25分)

题目来源:PTA(甲级)1012 The Best Rank (25分)
题目描述:
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A

题目大意:
根据输入的每个学生的成绩,计算出最好的成绩和排名,如果相同按照A>C>M>E的顺序,最后按要求输出

注意事项:

  • 注意出现成绩并列的情况
#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<map>
using namespace std;
struct student{
	//存放初始输入的学生信息
	string ID;
	int grade[4];
	int rank[4];
};
struct Result{
	//存放排序后最好的名次
	char course;
	int rank;
};

int index;
bool cmp(student stu1, student stu2)
{
	return stu1.grade[index] > stu2.grade[index];
}

char Rank(int i)
{
	if (i == 0)
		return 'C';
	else if (i == 1)
		return 'M';
	else
		return 'E';
}

int main() 
{
	int N, M;
	cin >> N >> M;
	student stu[2005];//存储学生信息
	map<string, Result>re;//存储排序结果
	for (int i = 0;i < N;i++)
	{
		cin >> stu[i].ID;
		for (int j = 0;j < 3;j++)
			cin >> stu[i].grade[j];
		stu[i].grade[3] = (stu[i].grade[0] + stu[i].grade[1] + stu[i].grade[2]) / 3;
	}
	//进行成绩排名
	for (index = 0;index < 4;index++)
	{
		sort(stu, stu + N, cmp);
		for (int i = 0;i < N;i++)
		{
			if((stu[i].grade[index]==stu[i-1].grade[index])&&(i!=0))
				//此处判断是为了排序中出现的并列情况
				stu[i].rank[index] = stu[i - 1].rank[index];
			else
				stu[i].rank[index] = i + 1;
				
		}
	}
	//将所需要的信息插入到数组中
	for (int i = 0;i < N;i++)
	{
		Result tmp;
		tmp.course = 'A';
		tmp.rank = stu[i].rank[3];
		for (int j = 0;j < 3;j++)
		{
			if (tmp.rank > stu[i].rank[j])
			{
				tmp.rank = stu[i].rank[j];
				tmp.course = Rank(j);
			}
		}
		re[stu[i].ID] = tmp;
	}

	//排序后的输出测试
	/*for (int i = 0;i < N;i++)
	{
		cout << "===============" << endl;
		cout << stu[i].ID << ":";
		for (int j = 0;j < 4;j++) {
			cout << stu[i].grade[j] << " " << stu[i].rank[j] << " ;";
		}
		cout << endl;
	}

	for (int i = 0;i < N;i++)
	{
		cout << "===============" << endl;
		cout << stu[i].ID << ":";
		cout << re[stu[i].ID].rank << " " << re[stu[i].ID].course<<endl;
	}*/

	while (M--)
	{
		string s;
		cin >> s;
		if (re.find(s) != re.end())
			cout << re[s].rank<<" " << re[s].course << endl;
		else
			cout << "N/A" << endl;
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值