PTA(甲级)1011 World Cup Betting (20分)

题目来源:PTA(甲级)1011 World Cup Betting (20分)
题目描述:
With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.
For example, 3 games’ odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.
Output Specification:
For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
Sample Output:
T T W 39.31

题目大意:
给定三场比赛和每一场的结果的赔率,问怎么下注使利润最大;(当然是每一场都选择赔率最大的结果)

题目思路:

  1. 输入的每场得赔率情况计算出最大的赔率以及每一场的结果,存储到相应的数组中
  2. 根据给点的计算公式,求出最大的利润
  3. 按照输出的格式要求进行输出

注意: 用到了memset,这个函数在PTA中要加上头文件,否则显示编译错误;但是在VS中可以不用

#include<iostream>
#include<string.h>  //这个头文件不加PTA跑不过
using namespace std;

char select_re(int i)
{
	char s;
	if (i == 0)
		s = 'W';
	else if (i == 1)
		s = 'T';
	else
		s = 'L';
	return s;
}

int main()
{
	char re[3];  //记录每一场的获胜情况
	float od[3];
	float odd;
	float max = 0;
	memset(od, 0, 3);
	memset(re, '0', 3);
	for (int i = 0;i < 3;i++)
	{
		for (int j = 0;j < 3;j++)
		{
			cin >> odd;
			if (odd > od[i])
			{
				od[i] = odd;
				re[i] = select_re(j);
			}
		}
	}
	max = (od[0] * od[1] * od[2] * 0.65 - 1) * 2;
	for (int i = 0;i < 3;i++)
		cout << re[i] << " ";
	printf("%.2lf\n", max);
	return 0;
}

    我用余生下了一个注,赌上了我的幸福
    因为我不知道这个奔赴是不是有意义
    恰是过去的错误让我学会了珍惜
    希望我爱上了最后一个可以让我爱的人
    ღ 只是单纯地想携手余生,只为你 ♥

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值