1016 Phone Bills (25 分)

1016 Phone Bills (25 分)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

有个巨坑,就是当客户没有花费时,不能输出他的任何信息。

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
typedef struct bill{
    char name[21];
    int month;
	int day;
	int hour;
	int minute;
	char state[21];     //on-line or off-line
    int order_present;
}client;
client list[1001];
int toll_perTime[24];   //每个时段的收费标准
int toll_wholeDay;      //通话一整天的收费
int N;
char NAME[24];          //缓存上一个人名
bool cmp(client A, client B){//双关键字排序
    if(strcmp(A.name, B.name) != 0)
        return strcmp(A.name, B.name) < 0;  
    else 
        return A.order_present < B.order_present;
}
int main(){
    int tmp;//每次通话的时长
    int cost=0;
    int total_cost=0;
    int flag = 0;
    for(int i=0; i<24; i++){
        cin>>toll_perTime[i];
        toll_wholeDay += toll_perTime[i]*60;
    }
    cin>>N;
    for(int i=0; i<N; i++){
        scanf("%s %d:%d:%d:%d %s", list[i].name, &list[i].month, &list[i].day, &list[i].hour, &list[i].minute, list[i].state);
        list[i].order_present = list[i].month*1000000 + list[i].day*10000 + list[i].hour*100 + list[i].minute;
    }
    sort(list, list+N, cmp);
    for(int i=0; i<N-1; i++){
        if(strcmp(list[i].name, list[i+1].name) == 0 && strcmp(list[i].state, "on-line") == 0 && strcmp(list[i+1].state, "off-line") == 0){
            if(strcmp(list[i].name, NAME) != 0){
                flag = 1;
                if(total_cost)
                    printf("Total amount: $%.2f\n", total_cost / 100.0);
                total_cost = 0;
                strcpy(NAME, list[i].name);
            }
            if(flag == 1){
                printf("%s %02d\n", list[i].name, list[i].month);
                flag = 0;
            }
            tmp = (list[i+1].day-list[i].day)*24*60 + (list[i+1].hour - list[i].hour)*60 
                                + (list[i+1].minute-list[i].minute);
            //按天计算通话时间
            cost = (list[i+1].day-list[i].day) * toll_wholeDay;
            //如果off-line的hour小于on-line的hour
            if(list[i].hour < list[i+1].hour){
                cost += list[i+1].minute * toll_perTime[list[i+1].hour % 24];
                cost += (60 - list[i].minute) * toll_perTime[list[i].hour % 24];
                for(int j=list[i].hour+1; j<list[i+1].hour; j++)
                    cost += toll_perTime[j]*60;
            }
            //如果off-line的hour大于on-line的hour
            else if(list[i].hour > list[i+1].hour){
                cost -= list[i].minute * toll_perTime[list[i].hour % 24];
                cost -= (60 - list[i+1].minute) * toll_perTime[list[i+1].hour % 24];
                for(int j=list[i].hour-1; j>list[i+1].hour; j--)
                    cost -= toll_perTime[j]*60;
            }
            //如果off-line是hour等于on-line的hour,而且off-line是miute 小于等于 on-line的minute
            else if(list[i].minute <= list[i+1].minute)
                cost += (list[i+1].minute-list[i].minute)*toll_perTime[list[i].hour % 24];
            else//如果off-line是hour等于on-line的hour,而且off-line是miute 大于 on-line的minute
                cost -= (list[i].minute-list[i+1].minute)*toll_perTime[list[i+1].hour % 24];
            total_cost += cost;
            printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n", list[i].day, list[i].hour, list[i].minute, 
                                                        list[i+1].day, list[i+1].hour, list[i+1].minute, tmp, cost / 100.0);
        }
    }
    if(total_cost)
        printf("Total amount: $%.2f\n", total_cost / 100.0);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值