UVa OJ
Immediate Decodability
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.
Examples: Assume an alphabet that has symbols {A, B, C, D}
The following code is immediately decodable:
A:01 B:10 C:0010 D:0000
but this one is not:
A:01 B:10 C:010 D:0000
(Note that A is a prefix of C)
Input
Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
The Sample Input describes the examples above.
Sample Input
01 10 0010 0000 9 01 10 010 0000 9
Sample Output
Set 1 is immediately decodable Set 2 is not immediately decodable题目大意就是每一个code都不能是其他code的前缀。
可以先通过排序,按照code的位数从小到大排序(这里有点小技巧,因为二维数组是不能直接排序的,可以通过改为结构体,或是用指针排序)
http://blog.csdn.net/unimen/article/details/6843977
#include<iostream>
#include<cstdio>
#include<cstring>
#include<ctype.h>
#include<algorithm>
using namespace std;
struct node
{
char str[10];
int x;
};
bool cmp(node s, node v)
{
return s.x<v.x;
}
node code[10000];
int main ()
{
int t=0,i,j,p=1;
while(gets(code[t].str))
{
bool isID=true;
if (code[t].str[0]=='9')
{
sort(code,code+t,cmp);
for (i=0; i<t; i++)
{
for (j=i+1; j<=t; j++)
{
int len=strlen(code[i].str),k;
for (k=0; k<len; k++)
if (code[i].str[k]!=code[j].str[k]) break;
if (k==len)
{
isID=false;
break;
}
}
if (!isID) break;
}
if (isID) printf("Set %d is immediately decodable\n",p);
else printf("Set %d is not immediately decodable\n",p);
t=0;
memset(code,0,sizeof(code));
p++;
}
else
{
code[t].x=strlen(code[t].str);
t++;
}
}
return 0;
}