BFS入门-A strange lift

Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?   

Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

Output For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
Sample Input
5 1 5
3 3 1 2 5
0
Sample Output
3

题解 标准的BFS,只不过只能向上和向下移动。向上是当前楼层层数加上楼层的数字,向下是当前楼层层数减去楼层的数字。需要求出从当前楼层最少需要按几次键到达指定层数。加上剪枝再考虑一些细节就能AC了。 代码 #include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
int main()
{
int N,A,B;
while(scanf("%d",&N))
{
if(N==0)break;
scanf("%d %d",&A,&B);
int i,j,fl[300]={0},count=0,use[300]={0};
for(i=1;i<=N;i++)scanf("%d",&fl[i]);
if(A==B)
{
printf("0\n");
continue;
}
if(A>N||B>N)
{
printf("-1\n");
continue;
}//排除特殊情况 
queue<int> qu;
qu.push(A);
use[A]=1;
for(;;)//BFS 
{
int l=qu.size(),next,now,flag=0;
count++;
while(l--)
{
now=qu.front();
qu.pop();
int num=0;
next=now+fl[now];//向上 
if(next==B)
{
printf("%d\n",count);
flag=1;
break;
}
if(next>0&&next<=N&&use[next]==0)//剪枝 
{
use[next]=1;
qu.push(next);
}
else num++;
next=now-fl[now];//向下 
if(next==B)
{
printf("%d\n",count);
flag=1;
break;
}
if(next>0&&next<=N&&use[next]==0)//剪枝
{
use[next]=1;
qu.push(next);
}
else num++;
if(num==2&&qu.size()==0)//已经访问完所有可到达的楼层还是没到达指定楼层就输出-1 
{
   printf("-1\n");
   flag=1;
   break;
}


}
if(flag)break;
}
}
return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值