BFS入门- Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17
Sample Output
4
题解

意思就是John追牛,John有三种移动方式,前进一步,后退一步,坐车就是移动到当前坐标的2倍。比较简单的BFS,就是有两种情况需要注意:一是当John的位置与牛相同时;二是当Joh的位置在牛的位置之前。

代码

#include<stdio.h>
#include<queue>
using namespace std;
int use[1001000]={0};
int main()
{
int N,K,now,next,count=0;
scanf("%d %d",&N,&K);
if(N==K)
{
printf("0\n");
return 0;
}
if(N>K)
{
printf("%d\n",N-K);
return 0;
}//排除特殊情况 
queue<int> qu;
qu.push(N);
use[N]=1;
for(;;)
{
int l=qu.size();
count++;//计数 
while(l--)//处理完这一步所有情况再进行下一步 
{
now=qu.front();
   qu.pop();
   next=now+1;
   if(next==K)
   {
  printf("%d\n",count);
  return 0;
   }
   else if(use[next]==0)
{
   qu.push(next);
       use[next]=1;
}
next=now*2;
   if(next==K)
   {
   printf("%d\n",count);
   return 0;
   }
   else if(next<2*K&&use[next]==0)
{
   qu.push(next);
       use[next]=1;
}
next=now-1;
   if(next==K)
   {
   printf("%d\n",count); 
   return 0;
   }
   else if(use[next]==0&&next>=0)
{
    qu.push(next);
        use[next]=1;
}
}
}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值