HDU - 2444(二分图染色模板+二分图匹配模板)

The Accomodation of Students

There are a group of students. Some of them may know each other, while others don’t. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don’t know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

Input

For each data set:
The first line gives two integers, n and m(1

Output

If these students cannot be divided into two groups, print “No”. Otherwise, print the maximum number of pairs that can be arranged in those rooms.

Sample Input

4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6

Sample Output

No
3

题意:有n个学生,其中m对学生相互认识,题目要求你把学生分成两部分,一个部分中的学生相互之间不认识,然后把他们分配到双人间中,房间中的俩人相互认识。不能分成两部分输出“No”(o小写),否则输出要开多少房间。

思路:模板。

#include <iostream>
#include <fstream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <set>
#include <cmath>
#include <algorithm>
#include <functional>
#define inf 0X3f3f3f3f
using namespace std;
typedef long long ll;
const int MAXN=1e5+10;
const int MAX=500+10;
const double eps=1e-6;

int n,m;
vector<int>G[MAX];
int vis[MAX];
int link[MAX];

void init(){
    memset(vis,-1,sizeof(vis));
    memset(link,-1,sizeof(link));
    for(int i=0;i<=n;i++)
        G[i].clear();
}

void addedge(int u,int v){
    G[u].push_back(v);
}

bool dfs(int node,int color){
    for(int i=0;i<G[node].size();i++){
        int v=G[node][i];
        if(vis[v]==-1){
            vis[v]=color^1;
            if(!dfs(v,vis[v]))
                return false;
        }
        else if(vis[v]==color)
            return false;
    }
    return true;
}

bool DFS(int node){
    for(int i=0;i<G[node].size();i++){
        int v=G[node][i];
        if(!vis[v]){
            vis[v]=1;
            if(link[v]==-1||DFS(link[v])){
                link[v]=node;
                return true;
            }
        }
    }
    return false;
}

int hungary(){
    int res=0;
    for(int i=1;i<=n;i++){
        memset(vis,0,sizeof(vis));
        if(DFS(i))
            res++;
    }
    return res;
}

bool juge(){
    for(int i=1;i<=n;i++){
        if(G[i].size()&&vis[i]==-1){
            vis[i]=0;
            if(!dfs(i,0))
                return false;
        }
    }
    return true;
}

int main(){
    #ifdef ONLINE_JUDGE
    #else
    freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    #endif
    while(cin>>n>>m){
        init();
        int u,v;
        for(int i=1;i<=m;i++){
            scanf("%d%d",&u,&v);
            addedge(u,v);
            addedge(v,u);
        }
        if(!juge())
            cout<<"No"<<endl;
        else
            cout<<hungary()/2<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值