hdu 2444-The Accomodation of Students(二分匹配)




The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 609    Accepted Submission(s): 298


Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 

Sample Input
      
      
4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
 

Sample Output
      
      
No 3



这道题的根本目的就是:求一个图是不是二分图,如果是二分图,求最大匹配。否则输出NO。


求一个图是不是二分图可以用并查集的方法做。

具体做法可以参考下面

http://blog.csdn.net/zsc09_leaf/article/details/6693479


上面那步完成后就很简单了。


#include<iostream>
using namespace std;

int f[210];
bool sex[210];	//相对于父节点的性别
const int MAXN = 210; 
int g[MAXN][MAXN], Mx[MAXN], My[MAXN], Nx, Ny; 
int chk[MAXN], Q[MAXN], prev[MAXN]; 
int MaxMatch(void) { 
  int res = 0; 
  int qs, qe; 
  memset(Mx, -1, sizeof(Mx)); 
  memset(My, -1, sizeof(My)); 
  memset(chk, -1, sizeof(chk)); 
  for (int i = 0; i < Nx; i++){ 
    if (Mx[i] == -1){ 
      qs = qe = 0; 
      Q[qe++] = i; 
      prev[i] = -1; 
      
      bool flag = 0; 
      while (qs < qe && !flag){ 
        int u = Q[qs]; 
        for (int v = 0; v < Ny && !flag; v++) 
          if (g[u][v] && chk[v] != i) { 
            chk[v] = i; Q[qe++] = My[v]; 
            if (My[v] >= 0) prev[My[v]] = u; 
            else { 
              flag = 1; 
              int d = u, e = v; 
              while (d != -1) { 
                int t = Mx[d]; 
                Mx[d] = e; My[e]  =  d;
                d = prev[d]; e = t; 
              } 
            } 
          } 
          qs++; 
      } 
      if (Mx[i] != -1) res++; 
    } 
  } 
  return res; 
} 
int find(int x,bool &se)
{
  se=true;
  int r=x;
  while(x!=f[x])
  {
    if(sex[x]==false)
      se=!se;
    x=f[x];
  }
  f[r]=x;
  sex[r]=se;
  return x;
}
int main()
{
  int t,i,n,m,a,b,cnt=1;
  while(scanf("%d%d",&n,&m)!=EOF)
  {
    Nx=Ny=n;
    memset(g,0,sizeof(g));
    for(i=1;i<=n;i++)
      f[i]=i,sex[i]=true;
    bool judge=true;
    while(m--)
    {
      scanf("%d%d",&a,&b);
      g[a-1][b-1]=true;
      if(judge)			//未异常
      {
        bool l1=0,l2=0;
        int fa=find(a,l1),fb=find(b,l2);
        if(fa==fb)
        {
          if(l1==l2)
            judge=false;
        }
        else
        {
          f[fa]=fb;
          sex[fa]=l1^l2;
        }
      }
    }
    if(!judge)
    {
      printf("No\n");
    }
    else
      printf("%d\n",MaxMatch());
  }
  return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值