POJ3259 Wormholes Floyd



Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 48494 Accepted: 17878

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

123


虫洞问题 ;

 从农场出发 然后 经过虫洞 虫洞   用负权   套用Floyd 模板 即可

/*
floyd 最短路径
 从某地出发 回到某地 
*/
#include<stdio.h>

#define inf 1<<29
#define N 1000
int map[N][N];
int n,m,w;
bool Floyd()
{
	int i,j,k;
	for(k=1;k<=n;k++)
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(map[i][j]>map[i][k]+map[k][j])
					map[i][j]=map[i][k]+map[k][j];
			}
//					printf("%d\n",map[i][i]); 
			if(map[i][i]<0)
			{
				return true;
			}
		}
	return false;	
}
int main()
{
	
	int i,j,k;
	int T;
	int x,y,z;
	while(~scanf("%d",&T))
	{
		while(T--)
		{
			scanf("%d %d %d",&n,&m,&w);
			for(i=1;i<=n;i++)
				for(j=1;j<=n;j++)
				{
					if(i==j)map[i][j]=0;
					else map[i][j]=inf;
				}
			for(i=1;i<=m;i++)
			{
				scanf("%d %d %d",&x,&y,&z);
				if(z<map[x][y])
				map[x][y]=map[y][x]=z;
			}
			for(i=1;i<=w;i++)
			{
				scanf("%d %d %d",&x,&y,&z);
				map[x][y]=-z;//负权值		
			}	
//			for(i=1;i<=10;i++)
//			{
//				for(j=1;j<=10;j++)
//					printf("%d ",map[i][j]);
//				printf("\n");
//			}
			printf(Floyd()?"YES\n":"NO\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值