Poj3259(floyd)

99 篇文章 2 订阅

POJ3259 - Wormholes

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2..  M+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: a bidirectional path between  S and  E that requires  Tseconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2..  MW+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.
Output
Lines 1..  F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accompl
 



     题意其实就是找是否存在负权边,故不能用迪杰斯特拉,Bellman 或者SPFA都可以 所以我敲了最简单的floyd。。。

#include<cstdio>  
#include<cstring>  
#include<algorithm>  
#include<iostream>  
using namespace std;  
int map[505][505],n,m,k,num=0;  
int floyd()  
{  
    int i,j,k,f=0;  
    for(k=1;k<=n;k++)  
        for(i=1;i<=n;i++){  
            for(j=1;j<=n;j++)  
            {  
                int t=map[i][k]+map[k][j];  
                if(map[i][j]>t)map[i][j]=t;  
            }  
            if(map[i][i]<0)return 1;  
    }  
    return f;  
}  
int main()  
{  
    int t;  
    scanf("%d",&t);  
    while(t--)  
    {  
        int i,j,a,b,c;  
        scanf("%d%d%d",&n,&m,&k);  
        memset(map,0x3f3f3f3f,sizeof(map));  
        for(i=1;i<=n;i++)map[i][i]=0;  
        for(i=1;i<=m;i++)  
        {  
            scanf("%d%d%d",&a,&b,&c);  
            if(c<map[a][b])map[a][b]=map[b][a]=c;  
        }  
        for(i=1;i<=k;i++)  
        {  
            scanf("%d%d%d",&a,&b,&c);  
            map[a][b]=-c;  
        }  
        if(floyd())printf("NO\n");  
        else printf("YES\n");  
    }  
    return 0;  
}  



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值