POJ3259 Wormholes Floyd判负圈

该博客探讨了如何使用Floyd算法解决POJ3259 Wormholes问题,这是一个关于寻找带有负权重虫洞的图中是否存在负环的图论问题。博主详细解释了题目要求,给出了可能的解题陷阱,并分享了他们的解决方案代码。
摘要由CSDN通过智能技术生成

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题目大意

输入样例数,然后输入三个数“点数,双向边数,单向边数”然后分别输入双向边,单向边(权是负的)。问图中有没有负圈

解题思路

陷阱1:用algorithm中min函数会超时,手写一个就可以过了
陷阱2:题目中有负圈,在输入边的时候要判断一下,保存最小的边

代码

#include <stdio.h>
const int INF = 10000000;
const int maxn = 510;
int eg[maxn][maxn];
int n;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--) {
        for(int i = 0 ; i < maxn ; i ++) {
            for(int j = 0 ; j < maxn ; j ++) {
                eg[i][j] = INF;
            }
        }
        int e1,e2;
        scanf("%d%d%d",&n,&e1,&e2);
        while(e1--) {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            if(eg[a][b] < c) continue;
            eg[a][b] = c;
            eg[b][a] = c;
        }
        while(e2--) {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            eg[a][b] = -c;
        }
        int isthere = 0;
        for(int k = 1 ; k <= n ; k ++) {
            for(int i = 1 ; i <= n ; i ++) {
                for(int j = 1 ; j <= n ; j ++) {
                    if(eg[i][k]+eg[k][j] < eg[i][j]) eg[i][j] = eg[i][k]+eg[k][j];
                }
                if(eg[i][i] < 0) {
                    isthere = 1;
                    break;
                }
            }
            if(isthere) break;
        }
        if(!isthere) printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值