1105 Spiral Matrix (25 分)(C++)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10​4​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

解题思路:

1.关于m,n的计算,由于开方后,得到的值一定是小于等于该数的平方,所以我们先计算n

2.定义一个二维数组result,result[i][j]记录行号为i,列号为j的值

3.在遍历过程中,一圈一圈地遍历,共 k 圈,k=n/2,每一圈在遍历时分为四条边,每条边的最后一个值留作下一条边的第一个值。

#include <iostream>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;
int main(){
    int N,m,n,cnt=0,k,i,j,wide,high,d;
    cin>>N;
    std::vector<int> v(N);
    for(i=0;i<N;i++)
        scanf("%d",&v[i]);
    sort(v.begin(), v.end(),greater<int>());
    n=sqrt(N);
    while(N%n!=0)
        n--;
    m=N/n;k=n/2;
    vector<vector<int>> result(m,vector<int> (n));
    for(d=0;d<k;d++){
        i=d;wide=n-d-1;high=m-d-1;
        for(j=d;j<wide;j++)
            result[i][j]=v[cnt++];
        for(;i<high;i++)
            result[i][j]=v[cnt++];
        for(;j>d;--j)
            result[i][j]=v[cnt++];
        for(;i>d;--i)
            result[i][j]=v[cnt++];
    }
    i=d,j=d;
    while(cnt<N)
    	result[i++][j]=v[cnt++];
    for(i=0;i<m;i++){
        for(j=0;j<n;j++){
            if(j!=0)
                printf(" ");
            printf("%d",result[i][j]);
        }
        printf("\n");
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值