HUT F - Constructing Roads

21 篇文章 0 订阅
4 篇文章 0 订阅

继续最短路模板题额。。

只是多了一个条件就是有些路是已经修好的,那么只要把修好的路之间的距离设为0,再Dijkstra一遍就出答案~

 

 

                                                             Constructing

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

 

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

 

#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <string.h>
using namespace std;
#define MAX 105
#define inf 0x7f7f7f
int n,m;
int mp[MAX][MAX];
int dis[MAX];
bool visit[MAX];

void prim( int st )
{
     for( int i=1 ; i<=n ; i++ ){
          visit[i] = false;
          dis[i] = mp[st][i];
     }     
     visit[st] = true;
     dis[st] = 0;
     int ans = 0;
     int tmp,k;
     for( int i=1 ; i<n ; i++ ){
          tmp = inf;
          for( int j=1 ; j<=n ; j++ )
               if( !visit[j] && tmp > dis[j] )
                   tmp = dis[ k = j ];
          ans += tmp;
          visit[k] = true;
          for( int j=1 ; j<=n ; j++ )
               if( !visit[j] && dis[j] > mp[k][j] )
                   dis[j] = mp[k][j];
     }
     printf("%d\n",ans);
}

int main()
{
    while( scanf("%d",&n) == 1 ){
           for( int i=1 ; i<=n ; i++ )
                for( int j=1 ; j<=n ; j++ )
                     scanf("%d",&mp[i][j]);
           scanf("%d",&m);
           int a,b;
           for( int i=1 ; i<=m ; i++ ){
                scanf("%d%d",&a,&b);     
                mp[a][b] = mp[b][a] = 0 ;  
           } 
           prim( 1 );
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值