HDU 1081 To The Max

毋庸置疑,这道题想要找到答案,必须枚举出所有的情况。

那么我们可以用两层for循环来枚举出第 i 行到第 j 行或者第 i 列到第 j 列的情况

由于题意是按行输入,所以我们要用两层循环来提取第 i 列到第 j 列的情况,接着就要考虑行的问题了

这里又要嵌套一个for循环来求出第 i 列到第 j 列( 截止到i第 k 行 )的值,也就是答案要求的值。

输入的时候,我们要做一个处理,就是第K列的数,代表前K列数的和 

0 -2 -7 0
 9 2 -6 2
-4 1 -4 1
-1 8 0 -2


处理后就是:
0  -2  -9  -9
9   11  5   7
-4 -3  -7  -6
-1  7   7   5


To The Max

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 40   Accepted Submission(s) : 28
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.

Input

The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2

Sample Output

15


#include <iostream>
#include <algorithm>
using namespace std;
const int M = 105;
int num[M][M];
int n;
int main()
{
	while( scanf("%d",&n) == 1 ){
		int a;
		//这里相当于增加了第0行和第0列,且值为0 
		memset( num , 0 , sizeof(num) );
		//输入的时候处理一下,第K列的数,代表前K列数的和 
		for( int i=1 ; i<=n ; i++ )
			for( int j=1 ; j<=n ; j++ ){
				scanf("%d",&a);
				num[i][j] = num[i][j-1]+a;	
			}
		int Max = -0x3f3f3f3f;
		int ans = -1;
		for( int i=1 ; i<=n ; i++ ){       		//第i列 
			for( int j=1 ; j<=i ; j++ ){		//第j列 
				ans = -1;
				for( int k=1 ; k<=n ; k++ ){	//第K行 
					if( ans > 0 )
						ans += num[k][i] - num[k][j-1];
					else
						ans = num[k][i] - num[k][j-1]; 
					if( ans > Max )
						Max = ans;
				}	
			}	
		}
		printf("%d\n",Max);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值