2021级-JAVA13 多线程

14 篇文章 24 订阅
2 篇文章 0 订阅

7-1 创建一个倒数计数线程

创建一个倒数计数线程。要求:1.该线程使用实现Runnable接口的写法;2.程序该线程每隔0.5秒打印输出一次倒数数值(数值为上一次数值减1)。

输入格式:

N(键盘输入一个整数)

输出格式:

每隔0.5秒打印输出一次剩余数

输入样例:

6

输出样例:

在这里给出相应的输出。例如:

6
5
4
3
2
1
0
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Test t=new Test();
        Thread th=new Thread(t);
        th.start();
    }
}
class Test implements Runnable {
    public void run() {
        Scanner in=new Scanner(System.in);
        int n=in.nextInt();
        for(int i=n;i>=0;i--)
        {
            System.out.println(i);
            try{
                Thread.sleep(500);
            } catch (InterruptedException e) {//InterruptedException异常为恢复中断抛InterruptedException的代表方法有:
                //1. java.lang.Object 类的 wait 方法
                //2. java.lang.Thread 类的 sleep 方法
                //3. java.lang.Thread 类的 join 方法
                e.printStackTrace();//在命令行打印异常信息在程序中出错的位置及原因
            }
        }
    }
}

7-2 程序改错题4

程序改错题。请修改下列代码,使程序能够输出正确的结果。

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Thread t = new Thread(new RunHandler());
        t.run();
    }
}

class RunHandler  {
    public void run() {
        Scanner in = new Scanner(System.in);
        int x = in.nextInt();
            System.out.println("run");
    }
}

输入格式:

输入一个整数x。

输出格式:

输出x行,每行一个字符串“run”。

输入样例:

4

输出样例:

run
run
run
run
import java.util.*;
public class Main {
    public static void main(String[] args) {
        Thread t = new Thread(new RunHandler());
        t.run();
    }
}

class RunHandler implements Runnable {
    public void run() {
        Scanner in = new Scanner(System.in);
        int x = in.nextInt();
        for(int i=0;i<x;i++)
        System.out.println("run");
    }
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

CRAEN

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值