ZOJ 3870


Team Formation

Time Limit: 3 Seconds      Memory Limit: 131072 KB

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be AB, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. AB > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input
2
3
1 2 3
5
1 2 3 4 5
Sample Output
1
6
 
 
题意:一组数里面选出两个数,使得这两个数异或之后大于它们中最大的数。问有多少个数。
思路:可以将所有数的最高位的1存进bit数组里面。后面只要满足另外一个数与其他数最高位那位对应的位为0的话,则异或后的数必然大于它们中较大的数。
与的运算:  1&1=1   1&0=0    0&1=0    异或运算   1^0=0    1^0=1   0^1=1   
所以只要判断 0&1==0 ---->   0^1=1  这样就将 0变成了1,所以异或后值自然变大。
关键点,预存储所有数最高位的1.
#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long ll;
int a[100005];
int bit[50];
void solve(int x)   //存储所有数最高位的一
{
    int Bit=31;
    while(Bit>=0)
    {
        if(x &(1<<Bit))
        {
            bit[Bit]++;   
            return;
        }
        Bit--;
    }
    return;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,i;
        cin>>n;
        ll ans=0;
        memset(bit,0,sizeof(bit));
        memset(a,0,sizeof(a));
        for(i=0;i<n;i++)
        {
            cin>>a[i];
            solve(a[i]);
        }
        for(i=0;i<n;i++)
        {
            int Bit=31;
            while(Bit>=0)   //找到一个大的数高位的一
            {
                if(a[i]&(1<<Bit))
                    break;
                Bit--;  
            }
            while(Bit>=0)  //之后只要将后面的0变成1,则必然数会变大。
            {
                if((a[i]&(1<<Bit))==0)
                    ans+=bit[Bit];
                Bit--;
            }
        }
        cout<<ans<<endl;
    }
}

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值