ZOJ - 3870 Team Formation(异或的巧妙运用)

Team Formation

Time Limit: 2 Seconds      Memory Limit: 131072 KB

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be AB, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. AB > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input
2
3
1 2 3
5
1 2 3 4 5
Sample Output
1
6

Author: LIN, Xi

Source: The 12th Zhejiang Provincial Collegiate Programming Contest

                  这道题~~有着整整10w的数据~所以在处理之前~我们先预处理一个数组ej【s】,表示二进制上最高位为s的数有多少个~~这样我们在寻找另一个可以相互匹配的数的时候~~只要拉个数位数比这个数低且他的二进制最高位值和那个位上的原来的数相反(例如10100(20)和1000(16))这样异或的数一定比两个数都大~~;

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int m[100005];
int ej[40];
void solve(int x)
{
	int w = 31;
	while (w>=0)
	{
		if (x&(1 << w))
		{
			ej[w]++;
			return;
		}
		w--;
	}
	return;
}
int main()
{
	int te;
	scanf("%d", &te);
	while (te--)
	{
		memset(ej, 0, sizeof(ej));
		int n;
		scanf("%d", &n);
		for (int s = 1; s <= n; s++)
		{
			scanf("%d", &m[s]);
			solve(m[s]);
		}
		int ans = 0;
		for (int s = 1; s <= n; s++)
		{
			int w = 31;
			while (w >= 0)
			{
				if (m[s]&(1 << w))
				{
					break;
				}
				w--;
			}
			for (int e = w - 1; e >= 0; e--)
			{
				if (!(m[s] & (1 << e)))
				{
					ans += ej[e];
				}
			}
		}
		cout << ans << endl;
	}
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值