Anniversary party

题目:

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings. 

输入:

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0

输出:

Output should contain the maximal sum of guests' ratings. 

样例:

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

 

题目大意:

乌拉尔州立大学将举办80周年校庆, 这所学校的员工有着分层的等级结构。校长为了让每一个人都能感到高兴,所以不希望存在一个员工和他的上司同时在场的情况。每个员工对这次校庆聚会都有一个期待值,让你给出邀请员工的清单,使得这场聚会的员工期待值总和最高。

思路:

这个管理结构是一个树形的结构,我们只要自底向上维护每一个员工及其所管理的子树的期望最大值就可以了。

dp[u][1]代表着,第u个员工如果来的话,以他为根节点的子树的期望值总和最大值。

dp[u][0]代表着,第u个员工如果不来的话,以他为根节点的子树的期望值总和最大值。

如果第u个员工来的话,它的儿子结点的员工就是不能来了,那么转移应该是dp[u][1] =exp(u)+ \sumdp[v][0]

如果第u个员工不来的话,它的儿子结点的员工就是可以来也可以不来,那么我们就取最大值,那么转移应该是dp[u][1] =0+ \summax(dp[v][0],dp[v][1])

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;
const int inf = 0x3f3f3f3f;
const int maxn = 6005;

int expect[maxn]; //每个员工的期望值
int vis[maxn]; //记录是否有上司,如果没有就是祖先节点了
int dp[maxn][2];

struct node
{
    int to, nxt;
} edges[maxn<<2];

int head[maxn<<2];
int tot;

void addEdge(int u, int v)
{
    edges[tot] = node{v,head[u]};
    head[u] = tot++;
}

void dfs(int u, int fa)
{
    dp[u][0] = 0;
    dp[u][1] = expect[u];
    for(int i = head[u]; ~i; i = edges[i].nxt)
    {
        int v = edges[i].to;
        if(v==fa) continue ;

        dfs(v,u);
        dp[u][1] += dp[v][0];
        dp[u][0] += max(dp[v][0],dp[v][1]);
    }
}


int main()
{
    int n;
    while(scanf("%d", &n)!=EOF)
    {
        for(int i = 1; i <= n; i++)
            scanf("%d", &expect[i]);

        tot = 1;
        memset(head,-1,sizeof(head));
        memset(vis,0,sizeof(vis));

        int u, v;
        while(scanf("%d%d", &u, &v)&&u)
        {
            addEdge(u,v);
            addEdge(v,u);
            vis[u] = 1;
        }

        int root;              //寻找整棵树的根节点,也就是校长
        for(int i = 1; i <= n; i++)
        {
            if(!vis[i])
            {
                root = i;
                break;
            }
        }

        dfs(root,-1);

        printf("%d\n", max(dp[root][1],dp[root][0]));
    }

    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值