POJ-2007 Scrambled Polygon(凸包)

题目:

 

A closed polygon is a figure bounded by a finite number of line segments. The intersections of the bounding line segments are called the vertices of the polygon. When one starts at any vertex of a closed polygon and traverses each bounding line segment exactly once, one comes back to the starting vertex. 

A closed polygon is called convex if the line segment joining any two points of the polygon lies in the polygon. Figure 1 shows a closed polygon which is convex and one which is not convex. (Informally, a closed polygon is convex if its border doesn't have any "dents".) 


The subject of this problem is a closed convex polygon in the coordinate plane, one of whose vertices is the origin (x = 0, y = 0). Figure 2 shows an example. Such a polygon will have two properties significant for this problem. 

The first property is that the vertices of the polygon will be confined to three or fewer of the four quadrants of the coordinate plane. In the example shown in Figure 2, none of the vertices are in the second quadrant (where x < 0, y > 0). 

To describe the second property, suppose you "take a trip" around the polygon: start at (0, 0), visit all other vertices exactly once, and arrive at (0, 0). As you visit each vertex (other than (0, 0)), draw the diagonal that connects the current vertex with (0, 0), and calculate the slope of this diagonal. Then, within each quadrant, the slopes of these diagonals will form a decreasing or increasing sequence of numbers, i.e., they will be sorted. Figure 3 illustrates this point. 

                                                                                          
                                   

Input

The input lists the vertices of a closed convex polygon in the plane. The number of lines in the input will be at least three but no more than 50. Each line contains the x and y coordinates of one vertex. Each x and y coordinate is an integer in the range -999..999. The vertex on the first line of the input file will be the origin, i.e., x = 0 and y = 0. Otherwise, the vertices may be in a scrambled order. Except for the origin, no vertex will be on the x-axis or the y-axis. No three vertices are colinear.

Output

The output lists the vertices of the given polygon, one vertex per line. Each vertex from the input appears exactly once in the output. The origin (0,0) is the vertex on the first line of the output. The order of vertices in the output will determine a trip taken along the polygon's border, in the counterclockwise direction. The output format for each vertex is (x,y) as shown below.

Sample Input
0 0
70 -50
60 30
-30 -50
80 20
50 -60
90 -20
-30 -40
-10 -60
90 10
Sample Output
(0,0)
(-30,-40)
(-30,-50)
(-10,-60)
(50,-60)
(70,-50)
(90,-20)
(90,10)
(80,20)
(60,30)

题目大意:

说得那么长,其实就一个意思:给你一个凸包,凸包上包含原点,让你从原点开始逆时针行走,输出凸点坐标

解题思路:

还是直接按着Graham算法求凸包,输出的时候处理一下就可以了

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>

using namespace std;
const int maxn = 1005;
const double eps = 1e-8;
const double PI = acos(-1.0);

//对于浮点数的,><=0的判断。
int sgn(double x)
{
    if(fabs(x)<eps) return 0;
    if(x<0) return -1;
    else return 1;
}
struct Point{
    double x, y;
    Point(){}
    Point(double _x, double _y)
    {
        x = _x;y = _y;
    }
    Point operator -(const Point &b)const{
        return Point(x-b.x,y-b.y);
    }
    Point operator +(const Point &b)const{
        return Point(x+b.x,y+b.y);
    }
    //叉积
    double operator ^(const Point &b)const{
        return x*b.y-y*b.x;
    }
    //点积
    double operator *(const Point &b)const{
        return x*b.x+y*b.y;
    }
    //绕原点旋转角度B(弧度制)后,x,y的变化。
    void transXY(double B)
    {
        double tx = x, ty = y;
        x = tx*cos(B)-ty*sin(B);
        y = tx*sin(B)+ty*cos(B);
    }
};
double dist(Point a, Point b)
{
    //勾股定理,使用点积
    return sqrt((a-b)*(a-b));
}

Point p[maxn];
int n;
double l;

//做极角排序
bool _cmp(Point p1,Point p2)
{
    double tmp = (p1-p[1])^(p2-p[1]); //向量叉乘
    if(sgn(tmp)>0) return true;
    else if(sgn(tmp)==0&&sgn(dist(p1,p[1])-dist(p2,p[1]))<=0)
        return true;
    else return false;
}

int Stack[maxn],top;

void Graham()
{
    Point p0;
    int k = 1;
    p0 = p[1];
    //找最下方的一个点
    for(int i = 2; i <= n; i++)
    {
        if(p0.y>p[i].y||(p0.y==p[i].y&&p0.x>p[i].x))
        {
            p0 = p[i];
            k = i;
        }
    }
    swap(p[1],p[k]);
    sort(p+2,p+n+1,_cmp);
    if(n == 1)
    {
        top = 1;
        Stack[0] = 1;
        return ;
    }
    if(n == 2)
    {
        top = 2;
        Stack[0] = 1;
        Stack[1] = 2;
        return ;
    }
    Stack[0] = 1;
    Stack[1] = 2;
    top = 2;
    for(int i = 3; i <= n; i++)
    {
        while(top>1&&sgn((p[Stack[top-1]]-p[Stack[top-2]])^(p[i]-p[Stack[top-2]]))<=0) top--;
        Stack[top++] = i;
    }

}

int main()
{
    n = 1;
    while(scanf("%lf%lf", &p[n].x, &p[n].y)!=EOF) n++;
    Graham();
    int flag = 0, k;
    for(int i = 0; i < top; i++)
    {
        if(p[Stack[i]].x == 0.0&&p[Stack[i]].y == 0.0)
        {
            flag = 1;
            k = i;
        }
        if(flag)
        {
            printf("(%.0f,%.0f)\n",p[Stack[i]].x,p[Stack[i]].y);
        }
    }
    for(int i = 0; i < k; i++)
    {
        printf("(%.0f,%.0f)\n",p[Stack[i]].x,p[Stack[i]].y);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值