最小生成树-字典序最小

最小生成树-字典序最小

求满足字典序最小的最小生成树,并输出。


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<cstring>
#include<string>
using namespace std;
const int MAXN = 110;
struct Node
{
	int u;
	int v;
	int w;
};
Node E[MAXN*MAXN];//保存边集
Node R[MAXN*MAXN];//保存字典序最小路径
int map[MAXN][MAXN], n, vset[MAXN], ans;
//保存各点关系的举证,顶点数,辅助数组【是否在同一个集合】,路径数
bool cmp(Node a, Node b)//贪心,按权值最小
{
	if (a.w == b.w)
	{
		if (a.u == b.u)
		{
			return a.v < b.v;
		}
		return a.u < b.u;
	}
	return a.w < b.w;
}
bool cmp_road(Node a, Node b)
{
	if (a.u == b.u)
	{
		return a.v < b.v;
	}
	return a.u < b.u;
}
void printf_road()
{
	if (ans != n - 1)//n个顶点只需n-1条边
	{
		cout << "该图非连通图" << endl;
		return;
	}
	sort(R, R + ans, cmp_road);//字典序最小排序
	for (int i = 0; i < ans; i++)
	{
		cout << "from" << R[i].u << "to" << R[i].v << " value:" << R[i].w << endl;
	}
}
int find(int x)//判断2个顶点是在同一个集合
{
	if (vset[x] == -1)
	{
		return x;
	}
	return vset[x] = find(vset[x]);
}
void kruskal()
{
	int k = 0;
	for (int i = 1; i <= n; i++)
	{
		for (int j = 1; j <= n; j++)
		{
			if (map[i][j]!=0)//map[i][j]==0等于无边
			{
				E[k].u = i;
				E[k].v = j;
				E[k].w = map[i][j];
				k++;
			}
		}
	}
	ans = 0;
	sort(E, E + k, cmp);
	memset(vset, -1, sizeof(vset));
	for (int j = 0; j < k&&ans<n-1; j++)
	{
		int u = E[j].u;
		int v = E[j].v;
		int t1 = find(u);
		int t2 = find(v);
		if (t1 != t2)
		{
			R[ans++] = E[j];
			vset[t1] = t2;
		}
	}
	printf_road();
}
int main()
{
	cin >> n;
	for (int i = 1; i <= n; i++)
	{
		for (int j = 1; j <= n; j++)
		{
			cin >> map[i][j];
		}
	}
	kruskal();
	return 0;
}

例题:ZOJ 3204

Connect them

Time Limit: 1 Second       Memory Limit: 32768 KB

You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is the same as connecting computers j and i). The cost of connecting computer i and computer j is cij. You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.

Given n and each cij , find the cheapest way to connect computers.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 < n <= 100). Then n lines follow, each of which contains n integers separated by a space. The j-th integer of the i-th line in these n lines is cij, indicating the cost of connecting computers i and j (cij = 0 means that you cannot connect them). 0 <= cij <= 60000, cij = cjicii = 0, 1 <= ij <= n.

Output

For each test case, if you can connect the computers together, output the method in in the following fomat:

i1 j1 i1 j1 ......

where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line. If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of "lexicography small") If you cannot connect them, just output "-1" in the line.

Sample Input

2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0

Sample Output

1 2 1 3
-1

Hints:
A solution A is a line of p integers: a1a2, ...ap.
Another solution B different from A is a line of q integers: b1b2, ...bq.
A is lexicographically smaller than B if and only if:
(1) there exists a positive integer r (r <= pr <= q) such that ai = bi for all 0 < i < r and ar < br 
OR
(2) p < q and ai = bi for all 0 < i <= p


Author:  CAO, Peng
Source:  The 6th Zhejiang Provincial Collegiate Programming Contest


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<cstring>
#include<string>
using namespace std;
const int MAXN = 110;
struct Node
{
	int u;
	int v;
	int w;
};
Node E[MAXN*MAXN];
struct road
{
	int u, v;
};
road R[MAXN*MAXN];
int map[MAXN][MAXN], n, vset[MAXN], ans;
bool cmp(Node a, Node b)
{
	if (a.w == b.w)
	{
		if (a.u == b.u)
		{
			return a.v < b.v;
		}
		return a.u < b.u;
	}
	return a.w < b.w;
}
bool cmp_road(road a, road b)
{
	if (a.u == b.u)
	{
		return a.v < b.v;
	}
	return a.u < b.u;
}
void printf_road()
{
	sort(R, R + ans, cmp_road);
	for (int i = 0; i < ans; i++)
	{
		cout << R[i].u << ' ' << R[i].v;
		if (i != ans - 1)
		{
			cout << ' ';
		}
	}
	cout << endl;
}
void kruskal()
{
	int k = 0;
	for (int i = 1; i <= n; i++)
	{
		for (int j = 1; j <= n; j++)
		{
			if (j>i&&map[i][j])
			{
				E[k].u = i;
				E[k].v = j;
				E[k].w = map[i][j];
				k++;
			}
		}
	}
	ans = 0;
	sort(E, E + k, cmp);
	for (int i = 1; i <= n; i++)
	{
		vset[i] = i;
	}
	for (int j = 0; j < k; j++)
	{
		int t1 = vset[E[j].u];
		int t2 = vset[E[j].v];
		if (t1 != t2)
		{
			R[ans].u = E[j].u;
			R[ans++].v = E[j].v;
			for (int i = 1; i <= n; i++)
			{
				if (vset[i] == t2)
				{
					vset[i] = t1;
				}
			}
		}
	}
}
int main()
{
	int t;
	cin >> t;
	while (t--)
	{
		cin >> n;
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				cin >> map[i][j];
			}
		}
		kruskal();
		if (ans != n - 1)
		{
			cout << "-1" << endl;
		}
		else
		{
			printf_road();
		}
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值