poj&&1753

54 篇文章 0 订阅
30 篇文章 0 订阅

http://poj.org/problem?id=1753

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

Choose any one of the 16 pieces.

Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
Sample Input

bwwb
bbwb
bwwb
bwww
Sample Output

4
这是一道经典的位运算+BFS的题,这里是把FILP game的每一种状态转化成一个点,然后用广搜求出达到目标状态所需要的最少步数。因为在该种游戏中就就两种颜色,可以把w看成1,把b看成0,而每次翻转,是把0变成1,或是把1变成0,正好这种变化可以用位运算的异或来实现,我怎么木有想到的。。。。come  on。。。。

代码:

#include<iostream>
#include<string.h>
#include<queue> 
using namespace std;
#define N 65536
bool visit[N];
int step[N];
queue<int>p;
int Trun(int state,int position)
{   state^=(1<<position);
   if(position-4>=0) state^=(1<<(position-4));
   if(position+4<16)  state^=(1<<(position+4));
   if(position%4>0) state^=(1<<(position-1));
   if(position%4<3)  state^=(1<<(position+1));
   return state;
}
bool BFS(int state)
{ int i;
   p.push(state);
   visit[state]=false;
     while(!p.empty())
     {  int s=p.front();
          p.pop();
          for( i=0;i<16;i++)
         {   state=Trun(s,i);
            if(visit[state])
             {  p.push(state);
                 visit[state]=false;
                 step[state]=step[s]+1;
                 if(state==0||state==65535)
                    return true;
              }
         }
     }
    return false;
}
int main()
{     memset(step,0,sizeof(step));
      memset(visit,true,sizeof(visit));
    int state=0;
    for(int i=0;i<16;++i)
    {     char s;
          cin>>s;
        if(s=='b')
         state+=(1<<i);
    }
    if(state==0||state==65535)
        cout<<0<<endl;
        else
        {   if(BFS(state))
             cout<<step[p.back()]<<endl;
             else   cout<<"Impossible"<<endl;
            
        }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值