1067 Sort with Swap(0,*)

题目描述:

Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}Swap(0, 3) => {4, 1, 2, 3, 0}Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10 3 5 7 2 6 4 9 0 8 1
Sample Output:
9
 
 
#include<iostream>
using namespace std;

int check(int a[],int begin,int end)//检查是否全部交换完成
{
	for(int i=begin;i<=end;i++)
	{
		if(a[i]!=i)
			return i;//如果还有没有交换完成的数据,就返回相应的下标
	}
	return -1;//如果已经全部交换完毕,就返回-1
}

int main()
{
	int n,key,sw=0,x,index;
	cin>>n;
	int * array=new int[n];
	for(int i=0 ; i<n; i++)
	{
		cin>>array[i];
		if(array[i]==0)
			key=i;//记录0所在的下标
	}
	
	while(check(array,0,n-1)!=-1)//没有交换完毕
	{
		while(key!=0)//当array[0]!=0的时候
		{
			for(int i=0;i<n;i++)
			{
				if(array[i]==key)
					x=i;
			}
			array[key]=key;
			array[x]=0;
			key=x;
			sw++;
		}
		if(array[0]==0 && check(array,0,n-1)!=-1)//当array[0]==0且没有交换完毕
		{
			index=check(array,1,n-1);
			array[0]=array[index];
			array[index]=0;
			key=index;
			sw++;
		}
	}
	cout<<sw<<endl;
	
	return 0;

}


 
 
   
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值