ACM: 一题大数求mod  poj2635    (…

                                               The Embarrassed Cryptographer

 

Description

ACM: <wbr>一题大数求mod <wbr> <wbr>poj2635 <wbr> <wbr> <wbr> <wbr>(学会大数求mod-。-!)The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.

Input

The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10100 and 2 <= L <= 106. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.

Output

For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.

Sample Input

143 10

 143 20

 667 20

 667 30

 2573 30

 2573 40

 0 0

Sample Output

GOOD

BAD 11

GOOD

BAD 23

GOOD

BAD 31 

题意:每一个数字可以两个素数的乘积. 如果其中一个小于L,输出BAD 和小于的那个素数. 否则输出GOOD.

个人思路:

              1. 大数喔,一般的成分肯定存不下.

              2. 大数拆分咯.找出这两个素数.

              3. 老问题大数求mod,打素数表,搜索咯. 

 

 代码:

 

#include <cstdio>
#include <iostream>
#include <string.h>
using namespace std;
#define MAX 1000005

 

int prime[MAX] = {0};
__int64 a[200];

 


void init()
{
        int i , j;
        for(i = 3; i <= MAX; i += 2)
       {
             for(j = 3; j <= i && j*i <= MAX; j += 2)
            {
                   prime[i*j] = 1;
             }
        }
}

 


bool mod(__int64 n,int divide)
{
        __int64 i , t = 0;
        for(i = divide; i >= 0; --i)
        {
              t = a[i] + t * 10000;
              t = t % n;
         }

 

          printf("t = %I64d\n",t);
          if(t % n == 0)
                 return true;
          else
                 return false;

}

 

int main()
{
      init();

 

//    freopen("a.txt","r",stdin);
       while(true)
       {
               memset(a,0,sizeof(a));
               int divide = 0;
               __int64 i;
               char K[1000];
               __int64 L;
               scanf("%s %I64d",K,&L);

 

               if(L == 0 && strcmp(K,"0") == 0)
                     break;
  
               int len = strlen(K);
               len--;
               while(len >= 0)
               {
                       int num = 1;
                       for(i = 0; i < 4; ++i)
                      {
                             if(len < 0)
                                   break;
                            a[divide] = a[divide] + num*(K[len]-'0');
                             len--;
                             num = num*10;
                      }
                      divide++;
               }
               divide--;

 

               bool flag = true;
               for(i = 2; i < L; i == 2? i++ : i += 2)
              {
                        if(prime[i] == 0 && mod(i,divide))
                       {
                              flag = false;
                               break;
                         }
              }

 

              if(flag == false)
             {
                       printf("BAD %I64d\n",i);
              }
              else
              {
                        printf("GOOD\n");
               }
         }

 

          return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值