ACM: 模拟题 poj 2993

                                                           Emag eht htiw Em Pleh

Description

This problem is a reverse case of the problem 2996. You are given the output of the problem H and your task is to find the corresponding input.

Input

according to output of problem 2996.

Output

according to input of problem 2996.

Sample Input

White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4

Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6

Sample Output

+---+---+---+---+---+---+---+---+

|.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|

+---+---+---+---+---+---+---+---+

|:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|

+---+---+---+---+---+---+---+---+

|...|:::|.n.|:::|...|:::|...|:p:|

+---+---+---+---+---+---+---+---+

|:::|...|:::|...|:::|...|:::|...|

+---+---+---+---+---+---+---+---+

|...|:::|...|:::|.P.|:::|...|:::|

+---+---+---+---+---+---+---+---+

|:P:|...|:::|...|:::|...|:::|...|

+---+---+---+---+---+---+---+---+

|.P.|:::|.P.|:P:|...|:P:|.P.|:P:|

+---+---+---+---+---+---+---+---+

|:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|

+---+---+---+---+---+---+---+---+

 

题意: 与2993一样.只是这次是将字符串描述还原棋盘.

解题思路:

              1. 没什么的.

代码:

#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
using namespace std;
#define MAX 10

char grid[MAX][MAX];

void init()
{
    memset(grid, 0, sizeof(grid));
    string str;
    cin >> str;
    getline(cin, str);
    int i = 0;
    while (str[i] != '\0')
    {
        i++;
        char ch;
        if (str[i] > 'Z')
            ch = 'P';
        else
        {
            ch = str[i];
            i++;
        }
        int y = str[i++] - 'a' + 1;
        int x = str[i++] - '0';
        x = 9 - x;
        grid[x][y] = ch;
    }
    cin >> str;
    getline(cin, str);
    i = 0;
    while (str[i] != '\0')
    {
        i++;
        char ch;
        if (str[i] > 'Z')
                ch = 'p';
        else
        {
                ch = str[i] + 'a' - 'A';
                i++;
        }
        int y = str[i++] - 'a' + 1;
        int x = str[i++] - '0';
        x = 9 - x;
        grid[x][y] = ch;
    }
}

void run()
{
    string line = "+---+---+---+---+---+---+---+---+";
    
    cout << line << endl;
    for(int i = 1; i < 9; ++i)
    {
        for(int j = 1; j < 9; ++j)
        {
            char ch1, ch2;
            ch1 = grid[i][j];
            if( (i+j) % 2 == 1 )
                ch2 = ':';
            else
                ch2 = '.';
            if(ch1 == 0)
                ch1 = ch2;
            printf("|%c%c%c",ch2,ch1,ch2);
        }
        printf("|\n");
        cout << line << endl;
    }
}

int main()
{
//    freopen("input.txt","r",stdin);
    init();
    run();
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值