ACM: 匈牙利算法 图论题 poj 3041 …

                                                                Asteroids

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4

1 1

1 3

2 2

3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.

OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

 

题意: Bessie 要消灭grid中所有的障碍, 她每发射一次可以摧毁一行 or 一列 的障碍.

          现在要用最少的发射次数消灭全部的障碍.

 

解题思路:

                1. 将行列分成两个集合, 现在要用最少的行的点,匹配列的点.

                2. 把问题抽象为二分图, 最大匹配的问题.

                3. 匈牙利算法水之.

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 505

int n, m;
int graph[MAX][MAX];
bool vis[MAX];
int state[MAX];

void read_graph()
{
    int u, v;
    memset(graph,0,sizeof(graph));
    for(int i = 1; i <= m; ++i)
    {
        scanf("%d %d",&u,&v);
        graph[u][v] = 1;
    }
}

bool find(int u)
{
    for(int v = 1; v <= n; ++v)
    {
        if(graph[u][v] > 0 && !vis[v])
        {
            vis[v] = true;
            if(state[v] == -1 || find(state[v]))
            {
                state[v] = u;
                return true;
            }
        }
    }
    return false;
}

int Edmonds()
{
    int result = 0;
    memset(state,-1,sizeof(state));
    for(int u = 1; u <= n; ++u)
    {
        memset(vis,false,sizeof(vis));
        if(find(u))
            result++;
    }
    return result;
}

int main()
{
//    freopen("input.txt","r",stdin);
    while(scanf("%d %d",&n,&m) != EOF)
    {
        read_graph();
        printf("%d\n",Edmonds());
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值