动态规划: poj1505改编题

                                                                                  Copying Books
Description
Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.

Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered 1, 2 ... m) that may have different number of pages (p1, p2 ... pm) and you want to make one copy of each of them. Your task is to divide these books among k scribes, k <= m. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers 0 = b0 < b1 < b2, ... < b k-1 <= bk = m such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k, 1 <= k <= m <= 500. At the second line, there are integers p1, p2, ... pm separated by spaces. All these values are positive and less than 10000000.

Output

For each case, print exactly one line. The line must contain the input succession p1, p2, ... pm divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character ('/') to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash.

If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

Sample Input

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100

Sample Output

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100
改变后:现在要计算出最小的时间内完成.
题意: n本书, m个人负责抄写. 问怎么划分可以使得时间花的最少. 每个人的抄写书本顺序是升序的.
解题思路:
        1. 确定动态规划的状态: dp[i][j]: 表示前i个人完成前j本书的最小时间.
        2. 假设: dp[i][j]. 前i-1个人完成了t本书的抄写.从t+1,t+2,...,j本书由第i个人
         负责抄写. 显然, dp[i][j] = min(dp[i][j],max(dp[i-1][t],Pt+1+Pt+2+...+Pj));
         (1 <= i <= m,i <= j <= m)
 
代码:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 505
int n, m;
int p[MAX];
int dp[MAX][MAX]; //dp[i][j]: 前i个人完成前j本书的最小时间.
int add[MAX];
int num;
inline int min(int a,int b)
{
 return a < b ? a : b;
}
inline int max(int a,int b)
{
 return a > b ? a : b;
}
int main()
{
 int i, j, k;
// freopen("input.txt","r",stdin);
 while(scanf("%d %d",&n,&m) != EOF)  //n本书, m个人
 {
  memset(dp,0,sizeof(dp));
  memset(p,0,sizeof(p));
  memset(add,-1,sizeof(add));
  num = 0;
  for(i = 0; i < n; ++i)
  {
   scanf("%d",&p[i]);
   if(i == 0)
    dp[1][i] = p[i];
   else
    dp[1][i] = dp[1][i-1] + p[i];
  }
  int minsize;
  int sum;
  for(i = 2; i <= m; ++i)
  {
   for(j = 0; j < n; ++j)
   {
    minsize = dp[1][j];
    sum = 0;
    for(k = j; k >= 0; --k) //枚举状态转移时的j的划分
    {
     sum += p[k];
     minsize = min(minsize,max(dp[i-1][k-1],sum));
    }
    dp[i][j] = minsize;
   }
  }
  printf("%d\n",dp[m][n-1]);
 }
 return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值