ACM: 动态规划 poj 1141

                                                                                                                              Brackets Sequence
Description
Let us define a regular brackets sequence in the following way:

1. Empty sequence is a regular sequence.
2. If S is a regular sequence, then (S) and [S] are both regular sequences.
3. If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]

题意: 将不规则的表达式变成规则的表达式, 添加的括号尽可能的少. []配对, ()配对.

解题思路:
         1. 动态规划题: 找状态先,再找状态转移方程.
         问题分析:
             (1). 状态dp[i][j]: 表示第i个到第j个找最少要添加括号的个数.
             (2). 分阶段:
                   当i == j时, dp[i][j] = 1;
                   当i < j时, dp[i][j] = min(i<=k<j) (dp[i][j],dp[i][k]+dp[k+1][j]);
                              记录路径path[i][j] = k; (递归时输出i到j之间的中间括号)
             (3).已经配对的情况: dp[i][j] = min(dp[i+1][j-1],dp[i][j]);
                   当dp[i][j] > dp[i+1][j-1]时, path[i][j] = -1; (直接输出配对括号.)
         2. 注意: 本题要考虑空字符的情况. 直接输出空行. 输入采用 cin.getline(str,MAX);

代码:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 150
const int INF = (1<<30);

char str[MAX];
int dp[MAX][MAX];
int path[MAX][MAX];

void printPath(int i,int j)
{
    if(i > j)
        return ;
if(i == j)     {
        if(str[i] == '(' || str[j] == ')')
            printf("()");
        else
            printf("[]");       
    }
    else
    {
        if(path[i][j] == -1)
        {
            printf("%c",str[i]);
            printPath(i+1,j-1);
            printf("%c",str[j]);
        }
        else
        {
            printPath(i,path[i][j]);
            printPath(path[i][j]+1,j);
        }
    }
}

int main()
{
//    freopen("input.txt","r",stdin);
    while(cin.getline(str,MAX))
    {
        memset(dp,0,sizeof(dp));
        int len = strlen(str);
        if(len == 0)
        {
            printf("\n");
            continue;
        }
        for(int i = 0; i < len; ++i)
            dp[i][i] = 1;
           
        for(int p = 1; p < len; ++p)
        {
            for(int i = 0; i < len-p; ++i)
            {
                int j = i+p;
                dp[i][j] = INF;
                if( (str[i] == '(' && str[j] == ')') || (str[i] == '[' && str[j] == ']') )
                {
                    if(dp[i][j] > dp[i+1][j-1])
                    {
                        dp[i][j] = dp[i+1][j-1];
                        path[i][j] = -1;
                    }
                }
                for(int k = i; k < j; ++k)
                {
                    if(dp[i][j] > dp[i][k] + dp[k+1][j])
                    {
                        dp[i][j] = dp[i][k] + dp[k+1][j];
                        path[i][j] = k;
                    }
                }
            }
        }
        printPath(0,len-1);
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值