ACM: 暴力题 poj 1338

                                                                                                                    Ugly Numbers
Description
Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ...
shows the first 10 ugly numbers. By convention, 1 is included.
Given the integer n,write a program to find and print the n'th ugly number.

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1

2
9
0

Sample Output

1

2
10

题意: 规定一种序列, 每个数的因子只有2,3,5. 规定1也在这个序列里面, 要你输出第n个这种序列的数.

解题思路:
      1. 第一反应, n <= 1500, 暴力打表.

代码:
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cmath>
using namespace std;
#define MAX 150005

int a[MAX];
int n;
int num;


void init()
{
    for(int i = 0; i < 30; ++i)
    {
        for(int j = 0; j < 30; ++j)
        {
            for(int k = 0; k <30; ++k)
            {
                a[num++] = pow(2,i)*pow(3,j)*pow(5,k);
            }
        }
    }
    qsort(a,num,sizeof(a[0]),cmp);
}

int main()
{
    init();
//    freopen("input.txt","r",stdin);
    while(scanf("%d",&n) != EOF && n != 0)
    {
        printf("%d\n",a[n-1]);
    }
   
    return 0;
}
int cmp(const void *a,const void *b)
{
    return *(int*)a - *(int*)b;
}

void init()
{
    for(int i = 0; i < 30; ++i)
    {
        for(int j = 0; j < 30; ++j)
        {
            for(int k = 0; k <30; ++k)
            {
                a[num++] = pow(2,i)*pow(3,j)*pow(5,k);
            }
        }
    }
    qsort(a,num,sizeof(a[0]),cmp);
}

int main()
{
    init();
//    freopen("input.txt","r",stdin);
    while(scanf("%d",&n) != EOF && n != 0)
    {
        printf("%d\n",a[n-1]);
    }
   
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值