ACM: 树的直径(两点最长距离) 图论…

Cow Marathon
Description
After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms.

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms.

Sample Input

7 6

1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52.

题意: 在这棵树的结构中找出两点间的最长距离.

解题思路:
                            1. 树上面求最长路简单路(无环). 就是树的直径问题.
                            2. 树的直径问题经典: 两遍BFS即可.
                            问题分析:
                                                (1). 一开始任取一个点u进行搜索查找出距离点u最远距离的点v和长度.
                                                (2). 第二次BFS则从第一次中的点v找出距离点v最远距离的点的路径长度.
                            3. 问题正确性.
                              证明:
                                                (1). 情况1: u在最长路上, 那么v一定是最长路的一端.
                                                            反证法: v不是在最长路的一端, 即有一个v1使得(u->v1)是最长路的一部分,
                                                                                      就有: dist(u->v1) > dist(u->v); 矛盾.
                                                              即: v在最长路的一端. (第二次BFS就可以找出距离v最远的点的长度.)
                                                (2). 情况2: u不再最长路上, 则有点u到点v的路与最长路一定有一个交点c.
                                                                                  并且(c->v)与最长路的后半段是重合的. 即v一定是最长路的一端.

代码:
#include <cstdio>
#include <iostream>
#include <cstring>
#include <vector>
using namespace std;
#define MAX 80005

struct node
{
      int v, w;
      int next;
}edges[MAX];

int n, m;
int first[MAX], num;
int dist[MAX], ans;
bool vis[MAX];
int point_u;

inline void add(int u,int v,int w)
{
      edges[num].v = v;
      edges[num].w = w;
      edges[num].next = first[u];
      first[u] = num++;
}

void read_graph()
{
      memset(first,-1,sizeof(first));
      int u, v, w;
      char ch;
      node t;
      ans = 0;
      num = 0;
      for(int i = 1; i <= m; ++i)
      {
            scanf("%d %d %d %c",&u,&v,&w,&ch);
            add(u,v,w);
            add(v,u,w);
      }
}

int bfs(int start)
{
      memset(vis,false,sizeof(vis));
      int front = 0, rear = 0;
      int qu[MAX], t;
      dist[rear] = 0;
      vis[start] = true;
      qu[rear++] = start;
     
      while(front < rear)
      {
            for(int e = first[qu[front]]; e != -1; e = edges[e].next)
            {
                  if( !vis[edges[e].v] )
                  {
                        dist[rear] = dist[front]+edges[e].w;
                        qu[rear] = edges[e].v;
                        vis[qu[rear]] = true;
                        if(dist[rear] > ans)
                        {
                              ans = dist[rear];
                              point_u = qu[rear];
                        }
                        rear++;
                  }
            }
            front++;
      }
      return ans;
}

int main()
{
//      freopen("input.txt","r",stdin);
      while(scanf("%d %d",&n,&m) != EOF)
      {
            read_graph();
            bfs(1);
            printf("%d\n",bfs(point_u));
      }
     
      return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值