ACM: 简单题 poj 1152 (简单题也wr…

An Easy Problem!
Description
Have you heard the fact "The base of every normal number system is 10" ? Of course, I am not talking about number systems like Stern Brockot Number System. This problem has nothing to do with this fact but may have some similarity.

You will be given an N based integer number R and you are given the guaranty that R is divisible by (N-1). You will have to print the smallest possible value for N. The range for N is 2 <= N <= 62 and the digit symbols for 62 based number is (0..9 and A..Z and a..z). Similarly, the digit symbols for 61 based number system is (0..9 and A..Z and a..y) and so on.

Input

Each line in the input will contain an integer (as defined in mathematics) number of any integer base (2..62). You will have to determine what is the smallest possible base of that number for the given conditions. No invalid number will be given as input. The largest size of the input file will be 32KB.

Output

If number with such condition is not possible output the line "such number is impossible!" For each line of input there will be only a single line of output. The output will always be in decimal number system.

Sample Input

3
5
A

Sample Output

4

6
11

题意:N进制的数R, 找出最小的N使得R%(N-1) == 0;

解题思路:
         1. 我们知道R%(N-1) == 0可以推出R的每一位数的和sum%(N-1) == 0.
         2. 注意的是 2 <= N <= 62

代码:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 32769

char str[MAX];

inline int max(int a,int b)
{
    return a > b ? a : b;
}

inline int value(char ch)
{
    if(ch >= '0' && ch <= '9')
        return ch - '0';
    else if(ch >= 'A' && ch <= 'Z')
        return ch - 'A' + 10;
    else
        return ch - 'a' + 36;
}

int main()
{
//    freopen("input.txt","r",stdin);
    while( scanf("%s",str) != EOF )
    {
        int len = strlen(str);
        int sum = 0;
        int base = 0;
        for(int i = 0; i < len; ++i)
        {
            int temp = value(str[i]);
            base = max(base,temp);
            sum += temp;
        }
       
        if(base == 0)
        {
            printf("2\n");
            continue;
        }
       
        int i;
        for(i = base; i < 62; ++i)
        {
            if(sum % i == 0)
                break;
        }
        if(i == 62)
            printf("such number is impossible!\n");
        else
            printf("%d\n",i+1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值