ACM: poj 3972 -&n…

Area of Polycubes

Description

A polycube is a solid made by gluing together unit cubes (one unit on each edge) on one or more faces. The figure in the lower-left is not a polycube because some cubes are attached along an edge. 

 

ACM: <wbr>poj <wbr>3972 <wbr>- <wbr>Area <wbr>of <wbr>Polycubes



For this problem, the polycube will be formed from unit cubes centered at integer lattice points in 3-space. The polycube will be built up one cube at a time, starting with a cube centered at (0,0,0). At each step of the process (after the first cube), the next cube must have a face in common with a cube previously included and not be the same as a block previously included. For example, a 1-by-1-by-5 block (as shown above in the upper-left polycube) could be built up as: 

(0,0,0) (0,0,1) (0,0,2) (0,0,3) (0,0,4) 

and a 2-by-2-by-2 cube (upper-right figure) could be built as: 

(0,0,0) (0,0,1) (0,1,1) (0,1,0) (1,0,0) (1,0,1) (1,1,1) (1,1,0) 

Since the surface of the polycube is made up of unit squares, its area is an integer. 

Write a program which takes as input a sequence of integer lattice points in 3-space and determines whether is correctly forms a polycube and, if so, what the surface area of the polycube is.

Input

The first line of input contains a single integer N, (1 <= N <= 1000) which is the number of data sets that follow. Each data set consists of multiple lines of input. The first line contains the number of points P, (1 <= P <= 100) in the problem instance. Each succeeding line contains the centers of the cubes, eight to a line (except possibly for the last line). Each center is given as 3 integers, separated by commas. The points are separated by a single space.

Output

For each data set, you should generate one line of output with the following values: The data set number as a decimal integer (start counting at one), a space and the surface area of the polycube if it is correctly formed, OR, if it is not correctly formed, the string “NO” a space and the index (starting with 1) of the first cube which does not share a face with a previous cube. Note that the surface area includes the area of any included holes.

Sample Input

4

5

0,0,0 0,0,1 0,0,2 0,0,3 0,0,4

8

0,0,0 0,0,1 0,1,0 0,1,1 1,0,0 1,0,1 1,1,0 1,1,1

4

0,0,0 0,0,1 1,1,0 1,1,1

20

0,0,0 0,0,1 0,0,2 0,1,2 0,2,2 0,2,1 0,2,0 0,1,0

1,0,0 2,0,0 1,0,2 2,0,2 1,2,2 2,2,2 1,2,0 2,2,0

2,1,0 2,1,2 2,0,1 2,2,1

Sample Output

1 22

2 24

3 NO 3

4 72

 

题意: 在三维空间内生成多边形, 给出每一时刻生成的坐标(正方体第一个角). 要你判断是否不会出现

      重复位置和形成不合法(当前正方体与前面正方体没有一个面相邻), 否则输出表面积.

 

解题思路:

      1. 题意读懂即可, 用set类快速查找, 判断6各面是否有相互覆盖减去2即可.

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <set>
using namespace std;
#define MAX 1005

struct node
{
 int x, y, z;
 bool operator <(const node &a) const
 {
  if(x == a.x)
  {
   if(y == a.y) return z < a.z;
   else return y < a.y;
  }
  else return x < a.x;
 }
};

int dir[6][3] = { {0,0,1}, {0,0,-1}, {0,1,0}, {0,-1,0}, {1,0,0}, {-1,0,0} };

int n;
set st;

int main()
{
// freopen("input.txt", "r", stdin);
 int caseNum, num = 1;
 int i, j;
 scanf("%d", &caseNum);
 while(caseNum--)
 {
  scanf("%d", &n);
  int ans = 0;
  int flag = -1;

  st.clear();
  node temp;
  scanf("%d,%d,%d", &temp.x, &temp.y, &temp.z);
  st.insert(temp);
  for(i = 2; i <= n; ++i)
  {
   scanf("%d,%d,%d", &temp.x, &temp.y, &temp.z);
   if(flag == -1 && st.find(temp) != st.end())
    flag = i;

   if(flag == -1)
   {
    int cur = 0;
    for(j = 0; j < 6; ++j)
    {
     node t = temp;
     t.x += dir[j][2];
     t.y += dir[j][1];
     t.z += dir[j][0];

     if(st.find(t) != st.end())
      cur += 2;
    }

    if(cur != 0) ans += cur;
    else flag = i;
    st.insert(temp);
   }
  }

  if(flag == -1) printf("%d %d\n", num++, 6*n-ans);
  else printf("%d NO %d\n", num++, flag);
 }
 
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值