POJ3080——Blue Jeans

Blue Jeans
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16572 Accepted: 7367

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3                 //T组数据
2                 //n个串
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

Source



题目大意:

有T组测试数据,每组数据有n个字符串,求出最长的公共串,若长度相同,则输出字典序小的那个;

若公共串长度小于3,则输出  no significant commonalities 

思路:

直接暴力求解,以第一个为标准,穷举其他的串;


代码:

#include <iostream>
#include <cstring>

using namespace std;

int len = 60;  //最大长度

int main()
{
    int T;
    cin>>T;
    while( T-- )
    {
        int n;
        char DNA[11][len+1];
        cin>>n;
        for( int i = 0;i < n;i++ )
        {
            cin>>DNA[i];          //输入n个串
        }

        char post[len+1];       //最长的公共字串
        int endlen = 0;           //最长的公共字串长度
        int nowlen = 1;          //现在搜寻的长度

        for( int i = 0;;i++ )
        {
            char dna[len+1];        //暂存的公共子串
            int pos = i;                  //从pos位置开始找
            if( pos+nowlen>len )     //如果已经没有比当前长度还长的公共字串,则寻找  当前长度+1   长的公共字串
            {
                nowlen++;
                i = -1;
                if( nowlen>len )    //如果寻找的长度超过最长长度len  则跳出
                    break;
                continue;
            }

            int j;
            for( j = 0;j < nowlen;j++ )
            {
                dna[j] = DNA[0][pos++];     //以第一个为基准,从pos位置找出长度为nowlen的串,存到dna串中
            }
            dna[j] = '\0';

            int flag = 0;
            for( int k = 1;k < n;k++ )
            {
                if( !strstr(DNA[k],dna) )     //如果有一个串中没有dna串,标志变量改变,跳出
                {
                    flag = 1;
                    break;
                }
            }
            if( !flag )   //如果标志变量没有改变
            {
                if( nowlen>endlen )
                {
                    strcpy(post,dna);
                    endlen = nowlen;
                }
                else if( nowlen==endlen )
                {
                    if( strcmp(post,dna)>0 )
                    {
                        strcpy(post,dna);
                    }
                }
            }
        }
        if( endlen>=3 )
            cout<<post<<endl;
        else
            cout<<"no significant commonalities"<<endl;
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值