poj 3723 最大生成树


Conscription
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9737Accepted: 3460

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

Source

错因:
       起初想的是直接换成最小生成树来做,,后来才发现要处理一个比较麻烦的情况,也就是,当所有有亲密度的节点合并完后,没有关系的节点还要再判断(因为最后不一定所有的节点都合并在同一个森林中),,然后加上10000*森林个数,比较麻烦,所以最后还是换成了最大生成树,不过要注意e[i]不是从小到大排序了而是从大到小。

解答:
        核心算法:最大生成树,kruskal算法

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct edge{
int x,y,c;
}e[50008];
int par[20008],ans;
void init()
{
for(int i=0;i<=20005;i++)
par[i]=i;
for(int i=0;i<=50005;i++)
e[i].c=10000;
ans=0;
}
int find(int x)
{
if(par[x]!=x)
par[x]=find(par[x]);
return par[x];
}
bool cmp(edge a,edge b)
{
return a.c>b.c;
}
int kruskal(int r)
{
sort(e+1,e+r+1,cmp);
for(int i=1;i<=r;i++)
{
int u=find(e[i].x),v=find(e[i].y);
if(u!=v)
{
par[v]=u;
ans+=e[i].c;
} //直接合并祖先节点
}
return ans;
}
int main()
{
int n,m,r,temp,cas;
scanf("%d",&cas);
while(cas--)
{
scanf("%d %d %d",&n,&m,&r);
init();
for(int i=1;i<=r;i++)
{
scanf("%d %d %d",&e[i].x,&e[i].y,&e[i].c);
e[i].y+=10000;
}
printf("%d\n",10000*(n+m)-kruskal(r));
}
return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值