POJ3723 最大生成树

题目:

Conscription
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15672 Accepted: 5422

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

题意:

征募男兵n人,女兵m人。若没有任何关系,征集一个人要花10000元,但是若已经征募的人中有一些关系亲密的人,那么可以少花一些钱。给出一些男女关系即亲密度,征集一个人的费用是(10000-已经征募的人中和自己亲密度的最大值)。求征集所有人的最小费用。收集一名士兵时只能使用一种关系。

思路:

为了使费用最小,就要使关系亲密度最大。由于收集一个士兵只能使用一种关系,那么就是要求关系的最大生成树。

最大生成树的求法和最小生成树的求法大同小异,只要改变边排序的大小关系即可。

代码:

#include<cstdio>  
#include<cstdlib>  
#include<cmath>  
#include<cstring>  
#include<iostream>  
#include<algorithm>  
#include<queue>  
#include<map>  
#include<stack> 
#define sd(x) scanf("%d",&x)
#define ss(x) scanf("%s",x)
#define sc(x) scanf("%c",&x)
#define sf(x) scanf("%f",&x)
#define slf(x) scanf("%lf",&x)
#define slld(x) scanf("%lld",&x)
#define me(x,b) memset(x,b,sizeof(x))
#define pd(d) printf("%d\n",d);
#define plld(d) printf("%lld\n",d);
// #define Reast1nPeace

typedef long long ll;

using namespace std;

const int INF = 0x3f3f3f3f;

int n,m,r;

struct edge{
	int u,v,len;
}G[50010];

int fa[50010];

bool cmp(edge a, edge b){
	return a.len > b.len;
}

int get(int x){
	return fa[x]==x? x : fa[x]=get(fa[x]);
}

void unions(int x,int y){
	x = get(x);
	y = get(y);
	if(x != y){
		fa[x] = y;
	}
}

int kruskal(){
	for(int i = 0 ; i<=n+m ; i++){
		fa[i] = i;
	}
	sort(G,G+r,cmp);
	int ans = 0;
	for(int i = 0 ; i<r ; i++){
		edge now = G[i];
		if(get(now.u) != get(now.v)){
			unions(now.u,now.v);
			ans += now.len;
		}
	}
	return ans;
}

int main(){
	int T;
	int x,y,d;
	scanf("%d",&T);
	while(T--){
		scanf("%d %d %d",&n,&m,&r);
		for(int i = 0 ; i<r ; i++){
			scanf("%d %d %d",&x,&y,&d);
			G[i].u = x , G[i].v = n+y , G[i].len = d;
		}
		int ans = 10000*(n+m)-kruskal();
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值